Firmware 2.02.32: no WiFi


my SMP is usually connected using the built-in WiFi.

Today I was prompted for the firmware upgrade, which I installed.

The player restarted but couldn’t complete the install because no network connection was detected.

I plugged an Ethernet cable, which allowed the install to finish, but since then I’m unable to reconnect using WiFi, the settings have completely disappeared from the menu!

I tried restarting after removing the Ethernet cable, but still no WiFi option.

Am I missing something?


The only way I ever update firmware of any kind is by downloading the files and upgrading off a USB drive.  That avoids the network variable.

Hi, my problem is not about installing the update, it has finally installed fine. My problem is that I now can’t find any option to connect my WDTV Live via wifi as I used to, I need to use a wired connection, which is not what I want. Thanks.

I upgraded from 2.01.86 to the newest firmware without any problems using the USB method.  I know you’re having a problem with no WiFi, but I was just saying this to help others not upgrade over the network.  Using the USB method my WiFi connection and settings were not lost as what happened in your case.

That being said…

There is a menu item called “Setup”, and under that is a menu item called “Network Settings” and then under that “Network Setup”.  Is there no option to manually set up your WiFi?

The same thing has happened to me. After the 2.02.32 update I’m unable to get the WD to connect wireless again.

Try a Factory Reset   (Will revert all settings back to default)

Setup  > System  >  Device Reset  >  Reset All Settings Back to Factory Default

You need to turn off Auto Detect Wi-Fi Direct setup in order to get the normal wireless settings back that you are looking for. 

I know because I was having the exact same problem. 

I’ve just had this problem after a failed upgrade and I’ve just tried turning off the autodetect.  It’s now saying Unable to obtain an IP addres.  The WD TV has limited or no network connectivity.

PaulDormer wrote:

I’ve just had this problem after a failed upgrade …

Then you need to redo the upgrade.

This update was a TWO-STEP update…  (It has two portions of firmware upgraded separately in multiple steps.)

If BOTH steps didn’t complete, you need to re-install – via USB instead of network.

I’m having the same problem, and under network setup, the IP address is, as is the subnet mask, the gateway and the DNS.

All well and good, but when I go to the latest downloads page it seems only to have the previous version, and when I put the USB storage into the port, it doesn’t detect the new firmware.  I’ll have to go through the steps again when I have more time.

Link to firmware:

Open the VER file and change it to read:


Then save the files to USB and install. Note: Even after the upgrade is 100% complete, it’ll still tell you there’s a new version available – you’ll need to remove the USB (or delete the firmware files) to prevent that.


I have the same problem!!! After rollback at 2.0.86 the problem is still here!!! NO WIFI, NO POSSIBILITY TO CHOOSE WI FI or ETHERNET!!! 

I install from the file but… the problem is still here. NO WIFI no CHOOSE of network!!! I a REAL BUG!!!

Well, the good news is the upgrade went through.

The bad news is that there still isn’t a wifi connection.  All addresses still and attempting to connect it says it can’t obtain an IP address.

I have the same problem as well.

I was able to finish the update to 2.02.32, but no WiFi.

What seems to be missing is the entire workflow for selecting Wired vs. Wireless, and selecting a network to connect to.  Network Settings take you directly to the Automatic vs. Manual setup for your IP, DNS, etc, but without actually being able to connect to a wireless network that page is of no value.  I had no WiFi issues before this firmware update.

I’m hoping that someone has a bug fix or solution soon.

My unit upgraded to the latest firmware without trouble. Wirless is available and works although I prefer wired instead.


We have passed this along to support.

Thanks - if it helps, I was connected over WiFi when first kicking off the firmware update.  It failed on part 2 due to no longer having a WiFi connection.  I was able to complete the upgrade by wiring in to an ethernet cable, but still can’t get the wireless option to appear.

Hi, happy to report that after disabling WiFiDirect auto-detect and resetting to factory defaults, the Wired/Wireless network setup option reappeared and Wifi is working again. Thanks to everyone.