Wireless stopped working after firmware downgrade/rollback

Hi all,

Like many others here, I had major performance issues after upgrading to 2.02.32 (extremely slow and unresponsive interface).

Tonight I decided to rollback to the previous firmware using the instructions here:


The rollback seemed to be successful, but after booting up, I could not set up WiFi (“Wireless”) any more. When I go to setup-> network settings-> network setup, I only see “automatic” and “manual” options available, instead of “wired” and “wireless”.

I’ve tried factory resetting via the menu, as well as the physical reset button. I also re flashed the rollback firmware multiple times, and I even manually flashed the 2.02.32 firmware one more time to see if I could regain WiFi. I’m having no luck, and no way to connect to my PC any more, on any firmware! Any help would be appreciated.

On the bottom of the device, it is labeled “WD TV Live Streaming Media Player”.

P/N: WDBHG70000NBK-02

The unit was purchased brand new from Costco more than a year ago and I’ve never had any WiFi issues until now.


Have you tried unplugging all the cables from the unit and connecting that again? Make sure that you don’t have an Ethernet cable attached.

I did have the cables unplugged last night when trying to troubleshoot, it didn’t help.

I also never had an Ethernet cable plugged in, ever.

Update for anyone else who may be experiencing the same problem:

I left the device powered down, but plugged in overnight, and when I turned it on in the morning, the network setup menu showed wired and wireless this time.

I don’t have any explanation for this, but everything is working now.