[Finally new firmware released][SN850X] The driver detected a controller error on \Device\RaidPort0

OS: Win 11 X64 22H2 22621.963 (clean install)
CPU: Intel i9-9900K
MB: Z390 MAXIMUS XI HERO (with latest BIOS & Driver installed)
SSD: SN850X 4TB with System install

Please help to check this issues, thank you very much.
Problem happened when reboot system.

Similar issues reported from internet, please help to check this issue.

Another reported links:

I also get this error. Clean installed Windows 11, brand new WD Sn850x 2TB.
The error only pops up when the pc is booting/rebooting or wakes up from sleep.

New build, clean install of Windows 11. I have 1 Samsung 990 Pro set as my boot drive, and 3 4TB SN850Xs on an Asus Z790 Apex motherboard, as well as a couple SATA drives. I get the stornvme error every reboot, without fail, on each SN850X; no issues at all with any of the other drive. Thus far I have not experienced instability, just the initial error messages.

OS: Windows 11 22h2
MB: Asus Z790E Strix
CPU: 13900K
GPU: Asus TUF OC 4090
PSU: 1200W
SN850 500GB
SN850X 1TB
SN850X 1 TB

Logging same error on every boot/reboot(raid port 2, and raid port 3) since the PC was built. Running current BIOS, and Drivers. Doesn’t seem to effect the 850, just the two 850x drives. No instability, or crashes.

WD reply to me re-intstall Windows and check WD dashboard healthy status…
I already re-install my system and check healthy and is normal.
I decide to change my CPU/MB and to see if this problem still exist.

If still exist, i will refund and buy 990 PRO or p44 pro…

Getting this error too Windows 11 22H2 Z790-E STRIX.
The driver detected a controller error on \Device\RaidPort1.
Something is wrong with the SSD firmware.


After change to 13700K/Z690, I still face this problem.

WD Dashboard is normal and the temperature is fine, the system is totally clean installed.

I have contact WD support again… :disappointed:

I think this is common issue…not fault ssd.

I have been getting this issue on my brand now build also for months now. I have two sn850x drives (2tb and 4tb) and both exhibit this error, causing my computer to BSOD multiple times per day.

Very frustrating to see that this is a known problem with MANY reported instances from different users on different sites with different hardware combinations, the only common denominator being the sn850x, and yet nothing has been done about it. Especially after spending many hundreds of dollars for top of the line WD ssds that have supposedly the best reliability and performance.

OS: Windows 11 22h2
MB: ASROCK x670e Taichi Carrara
CPU: Ryzen 9 7900x
GPU: EVGA 3080ti FTW3 Ultra
RAM: TEAMGROUP T-Force Delta RGB 32 GB (2 x 16 GB) DDR5-6000 CL30 Memory
PSU: EVGA 1300W Supernova
SN850X 2TB
SN850X 4 TB
SK Hynix Platinum P41 2 TB

WD can we please get a fix for this? A prosumer / enthusiast level halo product should not be causing BSOD’s for months and months without resolution from a company this large. It’s ridiculous

Does anyone know if we can tag support staff in this thread or something?

1 Like

Just look at all the users reporting here: https://www.reddit.com/r/framework/comments/yq6f6w/the_driver_detected_a_controller_error_on/

I have the same issue since installing my new SN850X 2tb nvme drive except the errors have pointed to RaidPort1 and RaidPort4.

I have submit a case to WD Support.
Maybe need more people to push them…


I reported this problem more than 1 month ago, the response is that the issue has been known, a new firmware will be released to fix, but no ETA. I fixed it myself by force installing another NVME driver instead of default Windows one.
I’m using this one:
64bit Micron NVMe driver v2.1.19.0 WHQL
The error code is gone and no crashes at all.

1 Like

WD Support reply to me as you said, they will release new firmware to fix this issue.
Let’s see when they can release.

This needs to be fixed urgently. I’m getting black screens all the time with my new SN850X and it’s always related to this error. My system is unusable in this state.

My new system ran for a month with no issues. Now I’m getting this \Device\RaidPort2 error.

MB: Asus z790-e
CPU: 13900K
GPU: Asus TUF 6900 XT
Drive 0: SN850X 2TB
Drive 1: SN850 2TB

I’ve installed the WD Dashboard and everything looks normal. Latest firmware on both drives.

Hoping for a fix.

EDIT: In my case, the error only happens when the computer goes to sleep. After a few seconds, the computer wakes up, all the fans run 100%, and Windows doesn’t come back. I have to force power down the machine. After reboot, the Event Viewer shows the \Device\RaidPort2 error.

I have the same problem. New system, updated everything, but I get this error \Device\RaidPort2. Most of the time I get the error when I play a video game.

MB : Asus TUF Gaming Z790-Plus D4
CPU : Intel*Core i5-13600K
PSU : be quiet! Straight power 11
RAM : Corsair Vengeance LPX 2 x 32GB, 3600 MHz, DDR4-RAM
SSD : WD Black SN850X 2TB

I really have to say this is very frustrating and i really hope for a fix asap.

Do you got BSOD or System Freeze?

Maybe you can try disable FreeSync (Adaptive-Sync) from amd driver and windows setting.

I do get BSOD everytime. Checking the eventlog shows that there is always the mentioned error seconds before the BSOD.

hmm, your problem is very similar with me.
Do you have Freesync or Adaptive-Sync monitor?
Try to disable Freesync or Adaptive-Sync from AMD driver (and from Winows Graphics VRR settings), let me know if it can resolve your BSOD problem.