Files in subdirectories not being copied/uploaded

When I drag and drop a directory that has multiple subdirectories, those subdirectories are created on MyCloud Home; however, the files in those subdirectories are not being copied or uploaded. So the directories end up being empty.

I tried it in Chrome, IE, and Firefox. This is from a Win10 machine. It seems to work from a Win7.

My Cloud Home (4TB)
Connection Type: Local
Software Version 5.0.3-103

Anyone else ever see this?
Any suggestions on how to fix this? I am not going to install an application nor ‘map a drive’ to the device.

I just tried with Windows 10 using chrome and was able to upload a folder with 9 folders and 31 files and everything uploaded as expected.

I would suggest installing WD discovery signing into your my cloud home account so it will mount as a drive and see if there are any similar issue for troubleshooting purposes.

Did the files in the SUB-folders upload? That is the issue I’m having.
Mounting as drive is NOT an option nor is installing WD discovery.