Uploading folders (not single files) via the web login

I have tried uploading a folder containing numerous sub folders to my WDMYCLOUD but, when I do this the folder structure and folders are removed and it just uploads all the files. I can’t seem to find how to upload the folder as it is as opposed to just dumping all the files or having to create the folder structure on the mycloud and copy each folders contents seperately. I don’t even know if that makes sense:-).

I am trying to do it remotely so using the a web browser (not dashboard).

I apologise is this has been asked before.

Thanks
Paul

@paulpies84 Have you tried copying the folder and pasting it to your My Cloud. I take it you are using files.mycloud.com .

Yes I am using files.mycloud.com but it won’t allow me to copy and then paste. I tried using CTRL/C and then CTRL/V but that wouldn’t work. I also tried right click but I dont get the option to paste.

@paulpies84 When you use the following, Upload files, this is when the problem occurs? The folder will not upload, only the files inside?

image

Correct yes, if I select the folder it then copies all the files but not the folders, the problem is I have files of the same names within different folders. I also tried putting them all into a zip and then uploading them which will work but I can’t unzip it without downloading it from there. Absolute nightmare

@paulpies84 Why don’t you create a new folder on your My Cloud with the same name and then place the files in that folder. See example image below. I just did this only I changed the name, I created User Manuals, instead of Manual Users. the files are the same and in the same order as shown on my computer.

Click on, tap or activate image to enlarge it.

You may be able to use WD Access too to move the folders/files.

https://support-en.wd.com/app/answers/detail/a_id/12449/kw/WD%20Access

That’s not going to help. I have a folder that houses multiple other folders and these folders have files within them. I thought I would be able to move the top level folder and that the folders/files in it would just move across as they are. Doing it your way is an option but it means I need to copy the contents of each sub folder separately which is a bit of a pain. Perhaps that’s the only way I can do it. Also the link you provided for WD access just throws out an internal server error but I will see if I can locate it.

Thanks

P

I am having the same problem.
Still can’t upload folder with subfolders.
How to resolve it?