Files fail to copy - 0x8007003B unexpected network error?

I’ve been trying to copy my files from my NAS to one of my PC’s … most of my files copy file but several (about 40 so far) return with this error:

If I right click on one of these problem files just to see properties I’ll get a long long delay and File Explorer will go into “Not Responding”

I’m running Windows 10 Pro (10.0.18362).

NAS firmware is 2.11.178. NAS diagnostics reports back as “Healthy” … Fan speed 1065rpm, Drives status all healthy, RAID status healthy.

Even copying a problem file withing the NAS from one location to another fails … so it’s clear NOT a network error.

I’ve run my Malware bytes and Windows Defender Virus scans and neither report any issues. Tried turning them off, problem persists. Tried turning Windows Firewall off and problem still persists.

What’s strange is that the problem is only “some” files.

Any suggestions?

Cheers, Rob.

Since I’m getting no responses form WD or anyone, I’ve had to find a working solution. That solution was to toss my EX4 and go with a QNAP TS-932X. The QNAP is setup for RAID 6 and is not having any issues copying files back and forth.

I’ve managed to recover about 95% of my files from the WD EX4 but some are forever lost. I run all the WD diagnostics and Windows diagnostics and nothing “Bad” was reported … even the WD full test which took 1 day to complete reported no errors … and yet if I right click on “some” files on the EX4 it takes explorer 5-10 minutes before the context menu appears (not even doing any activity just looking at file properties).

Either way, I need a RELIABLE NAS solution and the WD EX4 is far far far away from being reliable.