Failed DL4100


I’ve got a DL4100 which I promoted as the primary shared storage for the office. Everything worked OK until last Tuesday, when we found that we had no file or admin access. The LCD panel said everything was OK (raid healthy, server name, IP address… everything ok). I shut down the DL4100 using the power button, restarted and the problem was still there. I checked open ports and found that port 9000 and 3306 were open, so I guess that some services still work.

As we needed acccess to our files, I extracted the drives and installed them in a linux server. The linux server recognized the software RAID, which saved the day. I created a support case (#111015-10481546) but I’ve still not received any feedback from WD.

I’ve tried to install new drives in the DL4100, but can’t find how to format them, as there is still no acmin access. Is there any way to recover the service? Should I just file a RMA?


Try this:

  1. First as you have Web UI access, save the configuration as it is. Make a manual note of users that are defined and the access permissions as well as a note or all the other settings.
  2. Perform a System Only restore.
  3. Put all the settings back that you’ve noted and if necessary put users back and their passwords as well as permissions.
  4. Take another configuration back-up.

I think I know what this is. I think the Samba daemon has a glitch in it and I have reported it. I lost access to network shares yet everything worked fine. I had a valid configuration back-up taken while my DL4100 was working without problem. Restoring the configuration back-up returned the DL4100 to full functionality.

I;m going to try write an FAQ about this as well as the symptoms to watch for.

When your NAS is up and working, turn on SSH and also remember to keep a copy of the configuration back-up on the NAS in case there is a need to invoke the script to restore a configuration directly from the Linux command line.