Extremely slow transfer speeds, can't get FTP working

I’m pulling my hair out trying to get my EX2 working right. 

I’ve tried the MyCloud app as well as drag/drop with windows explorer (Windows 7 professional 64 bit). 

Transfer speeds at best are between 150 - 300kbps which is ridiculous. 

I’m using an ASUS RT-N66W Dual-Band Wireless-N900 Gigabit Router.

When I try to set up FTP per the manual’s instructions, I go into FileZilla, put (the IP of the device that I use to access the CP on the browser), admin as username, then the password for that account, and port 21 for the port. 

This is the response:

Response: 220---------- Welcome to Pure-FTPd [privsep] [TLS] ----------
Response: 220-You are user number 1 of 10 allowed.
Response: 220-Local time is now 13:56. Server port: 21.
Response: 220-IPv6 connections are also welcome on this server.
Response: 220 You will be disconnected after 10 minutes of inactivity.
Command: USER admin
Response: 331 Any password will work
Command: PASS **************
Response: 530 Please tell me who you are
Error: Critical error
Error: Could not connect to server

Any help is greatly appreciated. 

Thank you

Update, so after days of trying to get this **bleep** working, I try transferring another file today and it’s at around 45mbps right now - which is more tolerable than 150kbps! (drag and drop)…

You cannot use admin for ftp username. The admin account is ONLY for dashboard access.

You need to create an user acct, grant that user read or read-write access to a share and then after checking that the particular share has FTP access turned on (under Share Access setting on that share’s detail page) can you ftp in as that user.

Also, I suspect the previous time you were using wifi when transferring files, and that’s why it was so slow…45-55 MBps is the normal speed range when using a wired connection. Be careful, on Win7, even when you have an ethernet cable plugged in, Windows might still prefer to use the slower wifi connection. It depends on the priority in which connections are setup under Adapters and Bindings, and Windows most of the time sets wifi as a higher priority connection than a wired connection.

1 Like

I posted this in some other thread elsewhere but thought I’ll repeat this info about how to check the priority of connections (wifi vs wired) in Windows - and fix any slow connection issues if needed, by setting wired connection at a higher priority over wif connections (by using the green arrows on the right move wired connection to the top of the list).