External HD 1 TB not getting detected - Please help


My WD 1TB Hardisk is not getting detected on my desktop. I tried inserting other USB port hard drives which got detected. I have aorund 900 GB worth data including pictures, documents and movies which i have downloded after much labor. I need to know what am i supposed to do???

Also, my warranty card is not found so want to check can i call customer care of WD who can assist on what to do…or do i need to contact the local vendor in this case being ‘Anupam Stationary’ at Andheri to show them my HDD which they can refer to the company…

Please advice cos i am very worried about it…

Check to see if the drive appears on disk management

if you need to contact WD go here

Try this:

-Make sure your device is plugged into a USB port (even if it is not being recognized).

-Open command prompt (Start Menu>Accessories>Command Prompt), right click and run as administrator.

-Type this: sfc /scannow

-Let it run (this may take a few minutes).

-Afterwards, take it out, and plug it into a different USB port (if you do not have one, unplugging and replugging it in should have the same effect i would assume…)

After i did this i could plug it in and it would open with autoplay, no problems at all.

Thanks a lot :slight_smile: It worked fine for me. :slight_smile: