Ex4 SLOW transfer rate

Am I the only one running this slow?

I just setup my EX4 today. I installed 4 x 4TB WD Reds, and configured them as RAID 5. My file transfer tests to SMB shares are running at 10 - 11 MB/s.

I ran atop on the WD EX4 while the tests were running. During the file transfers, the NIC stayed around 10%, the 4 drives ran around 30%. There was no swapping. CPU would seem to spike a little, but nothing that would seem to be a bottleneck.

I am connected to a gigabit switch, and ethtool shows the link at 1000/Full. I have Win7 and Linux builds on the same switch that will transfer files between each other at 100MB/s. I don’t expect those speeds out of this NAS, but from reviews, I expected at least 50 - 60 MB/s.

Any help would be appreciated. I feel like I’m missing something simple.

root@wNAS Shared Videos # ethtool egiga0
Settings for egiga0:
Supported ports: [ TP MII ]
Supported link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
1000baseT/Half 1000baseT/Full
Supported pause frame use: No
Supports auto-negotiation: Yes
Advertised link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
1000baseT/Half 1000baseT/Full
Advertised pause frame use: Symmetric
Advertised auto-negotiation: Yes
Link partner advertised link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
1000baseT/Half 1000baseT/Full
Link partner advertised pause frame use: Symmetric Receive-only
Link partner advertised auto-negotiation: Yes
Speed: 1000Mb/s
Duplex: Full
Port: MII
PHYAD: 0
Transceiver: internal
Auto-negotiation: on
Link detected: yes

Thanks,

Kevin

Hi there,

Try different Ethernet cables, I have an EX4 unit and It does go faster than 10 MB/s, i did have an issue with on computer, it was not using the Ethernet port as Gigabit, however once i changed this computer it was working fine. I am not saying ht issue has to do with the computer, but it is always good to check everything is correctly setup.

Thank You. It did turn out to be a bad patch cable. I am now getting a consistent 40MB/s, Still slow for a GigE, but fast enough for my application.

If you want a good transfer rate with the nas use a gigabit swith or router with 1000 m/sec transfer rate maximum. Obviously you have a gigabit lan cardson the computers.

Use Cables in category 6, the quality of the cables is very important for the transfer rate.

at every reboot of my EX4 i have to ssh and run
/etc/init.d/wdphotodbmergerd stop
/etc/init.d/wdmcserverd stop
this stops the thumbnail creation.
why WD doesnt address this is inept.

If You use samba protocol (windows shared folders) 40MB/s - it’s normal speed for GigEth connection. I have similar result.

I use my WD EX4 for local shared storage and as a DLNA server and have learned that my performance/throughput improves markedly when I turn off cloud access under Settings -> General. I get slightly better throughput if I turn off media streaming in Settings -> Media and have not noticed any improvement if I disable iTunes. With cloud access disabled I get somewhere in the neighborhood of 15 to 20 MB transfer speeds when copying files to and from the NAS. I can live with that speed given the price point of this appliance. For any backups that require higher speeds I backup to my My Book Duo.

1 Like

I do this at every boot of my EX4.
ssh to the device.
/etc/init.d/wdphotodbmergerd stop
/etc/init.d/wdmcserverd stop
this stops the thumbnail creation, apparently.

Many Thanks jhawkinsvalrico, your posting is a huge asset to rectify my problems.