What data transfer speed should I expect from the EX4 in RAID 1?

My question is this: what kind of speed might I expect to get transferring a file from my PC to the EX4? Am I simply expecting too much? My average is about 2mbs.

There are a lot of posts about slow data transfer issues on the EX4. I’ve tried replacing cables, changing settings and I continue to experiment with no increase in speed. I’m up to date on firmware, cables all new cat5, etc. I am extremely frustrated by these slow speeds as I do a lot of video and my files can be pretty large. I am thinking to start from scratch in a JBOD environment.


Hello bmack94536, welcome to the WD Community. Your transfer rate can vary depending on your configuration, but 2MBs is definitely too slow for an EX4. Check the link below for some things you can try.

When transferring large files to or from a Personal Cloud drive, performance may be slower than expected

1 Like

Checked the link but I am also getting slow fear speed … Mine range from 2 -5mbs via wifi
Even though I have met the gigabit setup

I appreciate your post and link to the video. I have watched it and checked over my setup yet I cannot do anything to speed up my slow data transfer speeds. Also somewhat oddly, I find that I cannot transfer data into the pre-built public shares at all - permission is denied when I attempt that. I can only transfer data into folders that I have created under the Public share.

I have tried reset, no avail. All of my connections look good and strong. I have a gigabit port in my computer, cat5 cables and a router that is gigabit capable and tells me that it is set to 1000.

Is there an option to send this device back and try another? I’ve got quite a few hours in on this one.

I did convert the EX4 to a JBOD setup, rebooted all devices and while I can now transfer into the Public shares, I am still around the same 2mbs transfer speeds. I have also turned off my computer’s firewall.

are you using wifi or ethernet  LAN connection? 

I’ve been trying both wired and wireless connections. I have one machine on a wired LAN with cat5 cables, computer and EX4 attached to a gigabit router. I’ve also tried WAN with the same results.

I’ve ordered new cat6 cables and I am going to replace my existing cables with them to see what happens. I can always use the cables.

My router is a new Netgear r8000. Gigabit on all ethernet ports and the router says it is running at 1000. The EX4 has a green solid LED on the ethernet cable port, which means gigabit connection (I believe).

I’ve also tried both RAID1 and JBOD with no apparent impact on transfer speeds between the two setups.

I’m techie, but not a network guy, so perhaps I am overlooking something. But I’ve been looking really hard!

I’m happy to say that this evening I am getting what appear to be full speed data transfers on my EX4. Thank you to Western Digital and other posters for their assistance.

Today I reset the EX4 to the factory settings and did the same to my router. Once I brought the EX4 back online and set it back up again I had transfers in the 15-20MBs range on my wireless connection and, I presume, even faster speeds on my wired connections which I have not tested yet.

In any case, I am appreciative of all the help and hopeful that things keep on this course!

One note: in all my struggles with maintain a connection with the EX4 I found that I got better results when I changed the power management settings on my network adaptors. By default, it appears that Windows sets them to automatically turn off to save power when they are not being used. By not allowing the auto turnoff, I seem to have a much better experience in keeping connnected to the EX4 over a long period of time. I experienced this with both wired and wireless adaptors. It might be worth considering emphasizing this issue in future setup or troubleshooting instructions.

So u are saying
1 - reset ex4 & router to default/factory setting…
2 -disable auto turnoff on ex4?

I had recently restore my ex4 to default but had never done it on my Asus RT-n66, not sure what is required to default it.

I reset my router and EX4 to the factory defaults at the same time. The router was back online before the EX4 - I don’t know if that made a difference. After that, I had reasonable data transfer speeds.

I had to set my home WiFi back up but that was not a big deal.

I was also experiencing connectivity issues. The EX4 would suddenly become unavailable sometimes in the middle of large data transfers. So I went to my network adapter in Device Manager (Windows 8) and to Power Management once I selected the adaptor and I turned off the feature that lets the adapter sleep to save power.

For Windows 8 - Device Manager > Network adapters > (select your adapter - it should be easy to spot) > Right Click on it > Properties > Power Management > Then uncheck "Allow the computer to turn off this device to save power.

This is critical for wireless connections because your adapter will shut down, but this is also helpful for wired connections.

Last note - I have not yet set a static IP for my EX4 and I still get fairly decent performance from it. I will do a static IP later but I spent a lot of time looking at that issue previously as it is widely mentioned online and yet it turned out to be a distraction from the real problem I was having.

I had restore the EX4 and it was simple… but for the router I have concern… meaning all setting will be reverted to factory default.

I have set the WD energy saving to error.JPG

but my transfer speed is still this miserable slow

xfer speed.JPG

anymore advice…

I need to check with Asus what to do prior to a restore… like saving the config so that I can upload it again to set the router back to current working condition… I am also not a network or even so techie in this field.

So any advice is very very helpful…

have a good day

Are you on a wired or wireless network? If you are wireless then these speeds could be caused by your wireless speed limits.

There are a lot of things to check on. Are you using a gigabit router? Is the EX4 connected to it on a gigabit port? Is your computer also connected to the router on a gigabit port? Is your router speed and EX4 connection speed set to gigabit (1000)? Don’t rely on the “auto” speed settings - set speeds on your router and EX4 to 1000.

The speeds you show in your image are slow, but faster than what I used to have.


I just a quick speed test, see results in image.

Average speed on large transfers > 500MB I get about 32 megabytes/second.

I forgot to mention using RAID 5.

@ bmack94536

I am using wireless…

  My modem and router is Asus RT-N66U… my EX4 link speed is at 1000…

  My computer is using a Dlink wireless adaptor DWA140… think this adaptor is not capable of 1000 limit…

Need to borrow son adaptor to try…

Will report again after trying another adaptor

Just realized that my transfer rate to other NAS also that slow… Need to look at my Network setup