Error when trying to access to WD My Cloud

I have an Ethernet with three computers and two external hard drives: LaCie and WD My Cloud. In two computers (one with Windows 7 32 bit, the other with Windows 10 32 bit) I can see, in the Navigation Pane, under Network, both hard disks, and can work with their folders and files. With the other computer (Windows 10 64 bits, the main computer), I can see LaCie hard disk (and work with its folders and files), but when I click on the WD My Cloud I get the error message 0x80070035. I can only access to this hard disk by means of a shortcut with the IP of the hard disk (i.e., I have mapped the Public folder with a letter).

I have always had problems with WD My Cloud, especially after upgrading to Windows 10. I tried to solve my problems reseting completely the disk, and after that I cannot access to it by means of its name on the Network section of the Navigation Pane! I also constant-li get messages saying that the disk is disconnected or “WD My Cloud. Restarting the system. The system has rebooted” (I am translating from Spanish). When using File History: «Reconnect your drive. Your File History drive was disconnected for too long…».

I have tried many “solutions” I have found on the Internet (including the program ReImage Repair) without any success.

Does anybody have any advice?


Make sure you have the latest firmware version installed on your My Cloud and verify if the network discovery options are turned on from your Windows 10 PC by going to “Control Panel\Network and Internet\Network and Sharing Center\Advanced sharing settings”

Thanks. I have the latest firmare version (v04.05.00-315) and network discovery options turned on.

I had the same problem, I try with some solutions that I found in the internet but nothing works.

Recently I download and upgrade for Windows and this solve the problem.

Check if you have any upgrade pending to apply and I hope this solve the problema.

I am facing same problem. First time it comes after Dec16 update, I try to access my cloud drive and there is busy progress bar and after few minutes same error and message “Network path not found”, however after two or three tries it become accessible. On same pc my Buffalo Nas drive is working fine it is accessible like local system drives. I try everything to resolve problem with wd mycloud drive but at last i take the backup of whole drive about 2.4TB and factory reset the drive. It works at last after wasting so much time. Its only one month passed i did all this an another update comes last week and my drive get updated automatically and same problem i am facing now. its irritating now to wait for 10-15 min to get access the file system. I also notice that public folders are opening normally without taking time problem is with folders with login permissions. After removing permissions of these folders making them public problem is still their. I am requesting the wd support team to help with the problem.