Elements Portable (disk2s1) not mounting (Mac)

Hello everyone,
I just go my Elements portable drive and I hooked it up to my Mac. I get the “Do you want to back up now” window and I proceed from there. I come to a point where it asks me if I want to erase drive (I think there was some verbiage that said formatting was needed to proceed). Anyways, I click erase and for some reason it did not go through. I noticed that in disk utility, the device was showing up as ‘Elements’ originally , but now it says ‘disk2s1’. I cant get the device to mount at all and tried re-formatting but it gives me an error .

Anyone have any ideas?

Same problem here!!

1 Like

Had the same issue here… it’s been frustrating-

I tried on three different macs (2 mini macs and one macbook pro, including one PC). I’ve returned one before for the same issue because I thought it was defective. For all I know, all of WD Portable Elements drives may not work with Mac or at least aren’t made to be formatted it through a Mac.

I’ve reformatted mine on my work PC.seems to mount just fine after a couple of tries.

Here’s what I did - hope this one helps everyone else. Please let me know if this worked for you to.

You have to partition/format the disk on a PC - follow these instructions:

Come back to a mac, try to partition or erase with mac os (journaled)
It won’t let you know, but you still have to try it.

Back to PC, it will request to reformat your disk. reformat it with exFat.

Back to PC, your disk will mount as Untitled. It will work on both Macs and PC’s.

I did try formatting (and partition) to exFat on Mac but I got the same error you all have received.

Anyway, hope this helps everyone having this issue!