Dysfunction - buttons, battery..?

I have received a myPassport Wireless for christmas. On the first time I used it it seemed to work fine (power, wifi, file transfer…). But ever since that day it seems to be malfunctioning (I don’t use it often so it took me a while to realize there really was something wrong). I wonder if the battery or the buttons are dead…?
It is impossible to turn on if it is not plugged to a computer, nothing happens if I push the power button, even if I keep it pushed for a long time.
When I plug it to a computer (any computer) : sometimes nothing happens (red led slowly flashing), sometimes it turns the drive on and I can access it from the computer. It seems totally random, I always have to plug and unplug it several times so that it finally turns on.
When the drive is finally turned on, I can’t turn the WiFi on (same problem as with the power button).
When unplugged, the drive turns off automatically.
It is a pain to use, I never know how long it will take to access my files because it is so random.
Am I doing something wrong, or is the material faulty ?
I have tried several times to keep it plugged for a long time so that the battery gets fully charged but it doesn’t change anything.
I couldn’t install the firmware update because I can’t access the drive on WiFi and don’t have a SD card.
I have sent an e-mail to the WD Support about a month ago but never got an answer.
Do you know what I should do ?
Thanks for your help, and sorry about my english.

I suggest you download the complete user manual from WD Support and figure out how the thing works. Have you actually used the enclosed power supply to charge the battery since that is how you charge it and not from a computer.

You may want to take some time to read the user manual for the Passport Wireless.

The battery will only charge using the supplied power adapter, it cannot charge via USB. Also, the WIFI is disabled when the drive is plugged in via USB. It will act as a normal USB drive when plugged in via USB. So you could be looking at a dead battery. Plug it into a wall outlet using the adapter and the LED will change color as the battery charges,blinking red, to blinking yellow, to blinking green and then blinking blue. When it is solid blue, it is fully charged. Also, if you haven’t done so, I strongly suggest updating the firmware on the drive as we have added important updates regarding the battery and charging.

Thanks to you two for your quick answers. I had already referred to the user manual, but… I have to admit I had totally forgotten that the battery should be recharged with an AC adapter and not from a computer…! ;( the power supply was left in a corner of the room and I forgot it, as I’m so used to stuff that can be charged through the computer. So probably the battery was just too low to function correctly. I’ve found the power supply again so I’m charging it now, I’ll let you know if it gets better after that… feeling a bit silly here!

Forgiven, but you better spend time with the darn manual; the MPW is NOT a simple toaster!

Funny how much better it works now ! … thank you again for helping me and sorry for the stupid question.

It’s ok, @chloeclo - there are no stupid questions! :slight_smile:

I’m happy you were able to get answers - these kinds of questions are actually really useful for us here in HQ! Please feel free to let us know if there is any other way we can help!