DX4000 Some Different Errors with W10 Client Backup --HELP!

Upgraded my main client from Win7 to Win10. I then uninstalled and reinstalled connector as this blog recommends. No problems to that point.

From the client, I started the connector/launchpad. No problem with that.

BUT, then I clicked on Dashboard and I immediately received the following error. “Runtime error 217 at 500E8338” Then, strangely, despite the error message, the dashboard sign-in appeared, and after another 217 error message, the dashboard itself appeared and actually seemed to be working.

Similarly, I went to Shared Folders, and after another two 217 errors, successfully reached the shared folders.

When I try the Backup icon, the experience is similar with one major difference. I get the same error message and then the Backup Properties window appears. And it appears to let me start a manual backup.

But, then the backup fails immediately. Error message says “Cannot read the information on a drive that you want to back up.” It then suggests I run chkdsk on the client drive(s). It does not specify the drive. But, all of my client drives are working fine from the client. I will try chkdsk, but I don’t think I am having a drive failure, and besides the server did not seem to try any of the three drives I back up.

I would make sure the dashboard still works well from another PC. Windows 10 has been working fine. CHKDSK really does help. If not you may try to edit the backup to say just backup D: and see what happens

Good ideas. Thanks.

Turns out all of the client PCs attached to the DX4000, except one, are running fine, executing all DX400 functions from the client. And two of them run Win10, one of which is an upgrade and the other a new computer original install. There is also an XP machine attached, which links to DX4000 without problem. But, the original machine I wrote about, one of the WIN10 machines, was throwing off and refused to make a backup…

Originally, the errant machine gave me 217s AND wouldn’t do a backup. Wouldn’t even start one.

I ran chkdsk on the erring machine and to my surprise one of the 2TB drives had a few bad segments. I ran chkdsk in error-fixing mode and fixed the errors. No other software I have run, including Paragon HD Manager, has alerted me to the disk errors. Anyway, now that the disk errors are fixed, I can run successful backups and seemingly all other functions of the DX4000 system from the problem client. However, it remains a problem client, because I still get the 217 errors, despite the commands running OK.

Now my problem is how to get rid of the pesky little error 217 popups. Reinstall Connector again?

Nat Turner

The 217 error is just on the win 10? Can you post a screenshot of the error?

Hi Gramps,

This 217 error message was triggered by my clicking on Backup on the launchpad popup (shown). After the error message popped up, the Backup popup came up and showed that last night’s backup had been successful. So, the error message doesn’t SEEM to indicate any real problem anymore.

Nat Turner

Only on this one Win 10 box? Not sure. No 3rd party AV or firewall? If you want to uninstall or you just might try, there is a program on your box now, connector configuration wizard. Try that and see. Just runs it again

Yes, only on this one Win10 box. Other two Win10 clients work fine without getting the 217 error.

But, chkdsk seems to have cleared the major problem. Sentinel now making scheduled backups on this box, without error messages.

But, if I try to do a manual backup on this machine, it will do the backup OK, but only after throwing me a couple of 217 errors.

I tried a complete uninstall/restart/reinstall of the connector on this machine, but no change in error message problem.

Nat Turner