DX4000 Loading Recovery it takes too much time and ends rebooting

Hello, I´ve been reading a lot a post about this issue, but I still can make my Sentinel works
here is a little of my history:
I´m trying to perform a new recovery server, I already did the first, second and third steps on the manual, but I´m stick in the middle step (recreate my store)
it takes about 3 days, and suddenly it just reboots and start again with the “searching…” and nothing happens after few days (I left a week, no results)
I understand (for the Gramps post) that I have to make several times the thumb drive of the middle step, but I have made it about 8 times and same result
(I’m using a 16Gb 2.0 drive Kingston brand) here´s what I had done:
I´m sure the iso recovery image is correct: (I´ve checked the hash file, it´s correct)
I´ve had use two differents version of PANAM_iso recovery.iso, the 01-07-03-13 and the 1-7-5-17, and I also checked with the hash file (md5 checker)
I took off the 4 disk (they are 4TB each) and I put it in another PC and I wipe it with the “diskpart”, I put them back in the same order that I pulled back.
when I run the third step (Perform a recovery), always ends with “Bad Storage” here´s my log file in the thumb drive said:
… last part of the log file…
2014.04.27 09:19:33 - INFO - RaidCfg64 detected 4 drives
2014.04.27 09:19:33 - INFO - RaidCfg64 drive WD-[[DELETED]]: port=5
2014.04.27 09:19:33 - INFO - RaidCfg64 drive WD-[[DELETED]]: port=2
2014.04.27 09:19:33 - INFO - RaidCfg64 drive WD-[[DELETED]]: port=4
2014.04.27 09:19:33 - INFO - RaidCfg64 drive WD-[[DELETED]]: port=3
2014.04.27 09:19:33 - WARN - No RAID volume detected!
2014.04.27 09:19:33 - INFO - Checking RAID status (2): Volume Missing
2014.04.27 09:19:34 - ERROR - Volume is not in good state, please re-create it
2014.04.27 09:19:34 - INFO - =========== Recovery app END (5) ===========

I need to know if someone already pass for this issue:
How long I have to wait for the “loading recover” status on the second stage (Recreate my Storage)
How to create the array manually (what are the parameters) I Mean, the info of the partition of the array on each drive, to put it manually direct in the “Diskpart” command.
When I run the first stage, it request me for a password, it this password is for set on first time? or it the “previous password” that it had the server?
Other thing:
I mount the ISO image with the POWE**** ISO program, and the question is if I have the keep the program running as long as the process it´s finished
I´m using a switch-router connected to both equipment (the Sentinel and my PC) it´s a requisite? keep both connected to the same network? for the tree steps?
and Final question:
Should I use the latest version? PANAM-1-7-6-21.iso? I don´t find the hash file for that version…
anyone can point me to the right direction? or what I´m doing wrong?
any help will be appreciated
thanks for you help and time in advanced

I would suggest using whatever ISO you have that you can verify with a hash file. Step one is only needed if you had locked your drives. You can’t skip to step 3, you have to do the middle step and look at the log file in c:\wd on the thumb drive when it says done. At the end of the file it should say Happy Happy, Raid Created

If the middle step is hanging you probably have a bad download or thumb drive.

Look in the log file from doing the middle step. You might try a different thumb drive. I don’t think the middle step takes a real big one.

Thanks very much for you response Gramps,
I have note that there´s missing file in the “Perform a Recovery” step.

“2014.03.15 13:39:48 - ERROR - Unable to open file C:\wdrecovery\recoverycfg.xml”

and also, there´s an error on the part where “it reads” the volumes:

2014.03.15 13:39:53 - INFO - RaidCfg64 drive WD-WCC****404: port=5
2014.03.15 13:39:53 - INFO - RaidCfg64 drive WD-WCC*****504: port=2
2014.03.15 13:39:53 - INFO - RaidCfg64 drive WD-WCC*****441: port=4
2014.03.15 13:39:53 - INFO - RaidCfg64 drive WD-WCC******959: port=3
2014.03.15 13:39:53 - INFO - RAID volume status is ‘FAILED’!
2014.03.15 13:39:53 - INFO - Matched drive 3 serial WD-WCC******404 model WDC WD******AMB0 with white list entry Enterprise Storage 3 TB
2014.03.15 13:39:53 - INFO - Matched drive 0 serial WD-WCC******504 model WDC WD******AMB0 with white list entry Enterprise Storage 3 TB
2014.03.15 13:39:53 - INFO - Matched drive 2 serial WD-WCC******441 model WDC WD******AMB0 with white list entry Enterprise Storage 3 TB
2014.03.15 13:39:53 - INFO - Matched drive 1 serial WD-WCC*959 model WDC WD3AMB0 with white list entry Enterprise Storage 3 TB
2014.03.15 13:39:53 - **WARN - Drive ‘WD-*****404’ is not part of the RAID!**
2014.03.15 13:39:53 - INFO - Checking RAID status (1): Volume Does Not Contain All Valid Drives

I guest I have to run twice the second option, but recreating the thumb drive each time
how long do you think have to wait for the second stage? I mean, how do I know that I got a good thumb drive? how can I know that? (for getting sure about getting a good/working thumb drive?)

I see that file “deletes” every time I boot from USB, so I have to recreate it
What about the “version”? I think my WD4000 it´s pretty old, (at least 3 or 4 year)
should I use the newest version of ISO recovery? ( I see you suggest to use had hash verified).
thanks for all your help and suggestion.

I had forgotten a file gets deleted. You do have to make a new thumb drive each time.
Is it possible you missed one of the drives when you were doing diskpart/clean?

I would clean all 4 drives, make a new thumb drive and try again. If it errors again, start over with clean and a new thumb drive and leave out the 404 drive.

Why are you rebuilding to start with? Could that drive have issues?

Hello Gramps, thanks to be online.
I´m pretty sure that I diskpart/clean all the drives and I inserted in the original order, but I think I can do it again, just for getting sure, I´ll make a new thumb drive and I will try again (with the ISO recovery that I had for sure it has a good hash md5).

I was giving to me that server at the first instance, because the original owner (I´m a support company) had the technician resign, and let that server in that status (in recovering mode), so I´m trying to recover with a fresh start.
as far as I know, the 4 disk was in perfect working condition.

I´ll give a try one more time (That´s the way it might work… trying… trying…)
another question:
when I clean the disk, should I make any partition? or let the pen drive do it for me?
I read in another thread that I have to do it 2 times (the recreation of the thumb drive) and do it 2 times (the rebuild the array)
how much usually takes? keeping in mind that my sata drives, my recovery image and finally my pen drive it´s in perfect working order?
just to have an estimated of how much time wait for the best results.
thanks for your time and patience.

You just "normally need to do the middle step once. The LCD should say recreated I think. The key is the log file must say completed, RAID created. It should not take long at all. The 3rd step may take 6 hours

You do not need to do anything other than clean.

Ok, thanks for your help and time, I will post any results in here
just for the records and maybe other people found helpful this forum

for the moment, in my pen drive, it does´t show any log files, (does it create until it´s finish?)
I haven´t seen that log file every time my servers “reboots” and goes to “searching” mode in the display (I think the process never ends grateful)

on the other hand, my pen drive of the third option, it does appear. (the log file)

I´ll keep inform either way.
Thanks for you support

I would think it is writing to the log file constantly. You do see the wd folder? It is not hidden correct?

You need to leave the pen drive in until the LCD says success.

Hi.
Nope, I never seen the C:\wd folder, maybe that´s the problem
it never ends, that´s why it never write it at all.
I see an C:\WDRECOVER folder in my third thumb drive, that´s where mi log file it´s located
from now, it had already pass an hour ( I reset/clean with disport the 4 drives and I create a new thumb drive),
I boot with the newly fresh created thumb drive pressing the back button until it shows
Loading Recovery…
I was expecting the next step ("starting recover… or something) but, not, it just show:
Initializing Ok.
Loading Recovery.
it had been so, since an hour ago (1 hour with 12 minutes)

I don´t want “pull” the pen drive until at least, “the server reboots” (which it takes about 3 days)
I think this is wrong, it should´t take more than one day, right?

the 3rd step will never work until the second step recreate works. You have to have a success with the second step and look at the log file before you to the recover step

Thanks for the response.
I realize that, it had to finish the second step.
I was looking around more topics on the Sentinel DX400 forum
and I found this: from a fellow of Germany
he had the second step finish and post the following info:
it schowed the folling in the LCD:
It was taking from RichardL
on the thread “Error 503 Service unavailable…”

INITIALIZATION OK - LODING RECOVRY
RECOVERY INITIALIZATION
RECOVERY STARTED
in the logfile I found this:

Microsoft DiskPart version 6.1.7600
Copyright © 1999-2008 Microsoft Corporation.
On computer: MININT-K7IGT9S

Disk 0 is now the selected disk.

Partition ### Type Size Offset

Partition 1 System 100 MB 1024 KB
Partition 2 Reserved 128 MB 101 MB
Partition 3 Primary 60 GB 229 MB
Partition 4 Primary 3665 GB 60 GB
Data partition letter is: D

2013.07.17 10:18:51 - INFO - Created Data Partition flag file at ‘D:\wdrec_datapart.txt’
2013.07.17 10:18:51 - INFO - X:\windows\system32\ServerRecovery.exe
2013.07.17 10:18:51 - INFO - Started MS server recovery

And I was wondering…
If I put the partition just like he shows here, maybe it will work for the 3rd fase?
I don´t know if it works, but I can somehow manually enter the partition info just like this log file.
at least, the smaller partitions, assuming that I put the large partition settle to fix in my space left on the unit on each disk, with diskpart.
(replacing the large partition with my correspondent large partition)
it will be “jumping” the second stage of re-create the array.
I remember that it was 4 partition on my disks before “clean them”
Maybe I´m dreaming… but It looks like my second stage it not working… :disappointed:

If you do not have a raid configuration your only hope would be it would recover to the first disc. But I do not think it will do that…

what does the screen on your PC say while it is doing the recreate? I forget

Sorry to interrupt directly, but I am testing this right now (2x 2TB disks, also a DX4000 dated 2012).
On my test system “Storage OK” appears on the LCD within 2 minutes after “loading recovery”

Might be useful:

  • I am using an older 1GB USB stick
  • I made sure to safe eject the disk after diskpart clean (presumably you have it connected in an external USB enclosure)

Hi PatrickE,
oh, don´t worry, any suggestion here are welcome
I bought a new USB pen drive and I found that only takes about 2 minutes to pass the second stage (it re-creates the storage very fast)
I can´t believe that I spent more than 25 days trying to re-create the storage
thanks for your addition
I´m ready to “try” the third and final stage ( I hope all results in best results)
I´ll Post here the results.

Gramps:
in my PC only it says that it´s finish.
reboot my server with the stick on it and the displays would reads when the process finish
that´s all.

in the third phase, it “waits” the server to continue the restoration (I´m still in the part)
I´ll post here the results
I´m work mon-fri that´s why I did´t response until now.
thanks for you help, time and patience.

So a new pen drive “fixed” re-create?

Yes Gramps!
It looks like the new acquired USB pen drive, did the trick. (thanks Patrick)
I´m running right now the third step, without any convenient, but still have the wait.
right now, it´s formatting the drives.

when I got the “recover successful” (finished the second stage)
i just turn it off
I insert the next pen drive
and it boot, without any problem.
when I got the “Recovery Started” I just click next and the screen and ask for a new installation

I read a post when you spent more than 2 months figure out how to make an expected recover
so I did too.
now I understand why too many people spent too much time trying to recover the server
there´s too many variants involved

Here´s some info/tips from my experience…

*** The ISO file … before make the USB drives
(make sure to check you iso file with the md5 hash)

****use the correct pen drive to boot from the server and make the storage clean (it should only takes a few minutes, if it goes more… something it´s wrong).
**** use the correct pen drive to boot from the server and make the recovery
**** never disconnect from the PC when you are in the third step
*** be patience when you are making the third usb thumb drive to boot from server (it takes time, up to 15-20 minutes)
**** keep in mind that you have to recreate those pen drives, each time you use it
**** never boot from the same pen drive twice (it will not work, there´s a file which delete everytime you boot)
**** when booting for recovering the server, try to use a router/switch that assign dhcp, so when you
click next and the PC (after boot from the third option) you PC can find your server
*** The third step takes time… up to 6 hours when it´s working the way it gotta be.

still will posting the results.
I´m not finished yet with the recovery.

Well on March 4th I did suggest a new pen drive. Guess I was not clear meaning a different brand/capacity :slight_smile:

Just amazing it works at all headless LOL But tickled you are making progress.

Hello Gramps
I didn´t realize what you meant when you wrote “new pen drive” I always used the same USB, I just reformatted
when I decide to buy a new one, it works (because Patrick suggest a "old 1 GB stick)
I bought a new Sony 8 GB and do the trick.

Concern to the server, it took more than 8 hours (maybe 12 hours)
I did´t wait to finish, I just let all night running and today in the morning, the display can read:
Sentinel. 192.168.x.x
So, I just browse that IP address and start the setup to define hour, language and the password (very important)
and right now, has the:
"INITIAL CONFIG… 1% "
I´ll wait until it finish…
I´ll keep posting the result…
thanks for you help Gramps.

Well, everything went well
I have the server up and running
Infinitive thanks to Gramps, without his help, I wouldn´t have the server repair/restore

I´ve installed clients for both, Windows and Macs

thanks for all your help