Do not have permissions to access the newly installed and formatted drive

I have just installed a brand new WD 8TB Ultrastar DC HC320 HDD on Windows 10 Pro PC.
I have initialized drive with a single GBT partition and formatted the drive for NTFS.
When I try to write or even read the drive I get an “Access denied” error.
When I try to set up the security property of the drive using local admin account, I get the error “You must have Read permission to view the property of the object” and “You do not have permission to view or edit object’s permission settings”.
How could I gain access to the drive?

Hi @Ramzay,

Have you opened a Support Case? If not opened, for more information, please contact the WD Technical Support team for the best assistance and troubleshooting:

Usually, when your external hard drive shows the “Drive is not accessible. Access is denied” error message, it suggests that you don’t have the privilege of accessing the disk partition. So, to fix the issue, you have to take ownership to get permission.

Step 1. Right-click on the inaccessible hard drive, select “Properties”. Switch to the “Security” tab, where you should see the reason why you aren’t able to open the drive with the info saying “You must have Read permissions to view the properties of this object. Click Advanced to continue”. Then click “Advanced” as told.
Step 2. Click “Change” to attempt the operation with administrative permissions.
Step 3. When asked to select User or Group, choose the “Advanced” option first. In the Common Queries, select “Find Now”, which will give a list of search results of user names.

Generally, Windows adds four user groups to the Security, including Authenticated users, Administrators, Users, and systems. If you add just Administrators and System, you’ll disallow to access the disk and even read its properties such as the used & free space. That’s why you need to add the User’s account into the Security.

Scroll down to find the “Authenticated Users”, by clicking “OK” to add it.
Tip: If you don’t clearly know which section you’re missing in the Security, try to add several more names in the same way until you got the right permission. Otherwise, choose “Everyone” to allow access with no limit.

Step 4. Confirm saving the changes you’ve made. Return to the Explorer, and now my drive E shows normal again. I can open it without receiving any further error messages.
Hope this helps.