Access denied win10 WDBAAR5000ABK and WD30EFRX writing/reading problems


      in the last period my super happy 30 years old story with only WD HD changed completly.

first problem

I have a WDBAR5000ABK USB 2.5" external HDD, after updating my pc to win10 I am not able to access anymore to this HD.

I can access to the drive for only few seconds, then I retrive the error “access denied” and the light of the external drive is costantly blinding.

I tried from the “disk manage” tool to see if it was a problem of letter association but no way, I tried to change security permissions but no way to access even to these, I tried to remove the device from device manager and reinstall it…no way again. It looks like an incompatibility beetwen the drive and win10.

On the other way when I connect the drive to a win7 (or previous versions) I have no problem at all.

Can you please help me?

second problem

I bought few months ago a WD30EFRX drive just for backup and really using it not really frequently.

Now if I try to copy files to it, after some time the writing speed goes to 0MB/sec and if I reboot the pc the HD is blocking the boot of the pc because not reconized from the bios anymore.

I tried to move the HD on other desktops and the problem happened in the exact same way.

What I have to do? Even because I lost the receipt of the order and so I cannot do the RMA.

thanks a lot for your support on this

Welcome to the Community.

If the hard drive works fine on Windows 7 then it could be a permissions-related issue. Did you try manually taking ownership of your hard drive? Instructions are available in the following link:

On the other hand, if the second hard drive is truly a few months old then you should be able to replace it through WD even if you do not have the purchase receipt.