Denied access from PC?

Is it just me or has something happened recently with access to My Cloud?
Since day 1 I had set up a map drive in Windows to My Cloud and worked wonderfully. Appears since they pulled the plug on the Windows app (why?) it no longer works and get all kind of messages about network access issues, wanting a username and password (?) etc
Have tried looking at the forum but the “simple” fix of going via the web interface (which is ■■■■) to Manage Device falls over with I need to be connected to the local network (which is is)

Driving me mad and ready to throw it in the bin - any advice?

This is the My Cloud Home (MCH) subforum. If you have a ‘My Cloud’ which is completely different, then you should head over to the OS5 or OS3 subforum.

Assuming you do have a My Cloud Home (MCH) then there is a simple 3 minute video on how to enable local access which is only required for a one time set up of the local credential. The reason this is needed is so that by default, the MCH would not show all your personal storage on the local network where everyone locally could see if it is not password protected.

The video will tell you the 4 prerequisites to be able to connect locally and the most important one is that your router has to turn on UPnP which will allow the MCH to recognize that the user is on the same local network as the MCH box. Not all routers can do UPnP properly so try a different router if it is not showing local. It sometimes takes more than a few minutes for UPnP to connect properly.