Dead Caviar Green 2 TB. Possible PCB problem?

Hi, a few days ago i turned on my Western Digital My Book 2 TB,  but I noticed that windows didn’t mounted the drive, no letter appeared on My PC.  It is showed on System Hardware. I also tried on linux and wasn’t possible to mount. I opened the case and noticed that the PCB looks roasted in some parts, but I don’t know if that’s normal. I also tried connecting the disk directly to my PC but the result was the same.

Here are some photos of the hard disk PCB and the USB adapter:

Is there a problem with the PCB? what can I do? I will apreciate your help

Send a PM to  fzabkar, he’s the resident guru for this type of stuff.

Thanks for the advice! I sent a PM to fzabkar.

I sent him a PM the other day, but could you post any info he gave you here just in case he doesn’t get back to me and if there’s anyone else with this issue? My PCB looks exactly the same, so I’m sure it has happened to others as well.

Please advise the board number which is etched on the PCB.