Creating a second RAID1 Volume

I’ve  two disks in a RAID1 configuration.  I just got two more disks and want to create a second RAID1 volume.

Judging from the screenshot below, this seems to be possible. But I hesitate to click “Submit” - I expect this to have effect only on “ExtendVolume”, but several things on the page makes me fear this will also impact the existing RAID1 Volume on “DataVolume” and delete all data. Backing up 1TB of data over 10MB/s takes forever.

Can I safely submit? 

Thanks for all help!

ShareSpace.jpg

I can tell you what happened in my case - READ THROUGH TO THE END.

I’m running version 2.2.9 with 2 - 1 TB drives in 1 and 2.  I upgraded to 2 - 2 TB drives through WDs upgrade program.  I installed the 2 - 2TB drives in 3 and 4 which resulted in the same display you pictured.  I recognize that I then had different sized drives in 1 and 2 vs 3 and 4 which is not a supported/recommended configuration according to WD, however since it was a new volume and a separate RAID 1, I felt it would be fine and proceeded to apply the configuration.

 It work fine initially, however the following day I showed drive failures on DATAVOLUME drives 1 and 2.  I went to access the shares and they came up fine, so I figured it just may have been a glitch and rebooted the sharespace.  Upon reboot I was no longer able to access any shares, however webaccess showed all the shares were intact.  At different times with different drives inserted I was getting different faults, however I was no longer able to access any shares on the original volume.  EXTEND volume was working fine on 3 and 4.

I removed drives 1 and 2, and ultimately was able to recover all the data using LINUX EXT 2/3 volume data recovery software as RAID 1 was a simple mirror, however as you stated this took a VERY long time (weeks) using an external SATA HD docking station and several trials/errors to find the right software.  What ultimately worked the best was EASUS Data Recovery Wizard Pro from www.easus.com for about $80.  This is not an ad, just passing on what I found via web searches after trying many different window’s based LINUX recovery software packages for both RAID and standalone.  This works well for RAID 1 (mirror) configurations with minimum scan time required.

After backing up the data, I proceded to upgrade DATAVOLUME from the 1TB drive to the 2TB drive as follows:

I put in one of the original single 1 TB drives in bay 1 (with the corrupted DATAVOLUME) and booted the sharespace.  I inserted a 2TB drive in bay 2 from EXT Volume.  Note I was not able to boot the sharespace from drives 3/4 alone as the system software had not been replicated from the 1TB drives to the 2TB drives.   Under DISK MANAGER, I then clicked on CLEAN (ERASE, the icon to the right of drive 2, the 2TB drive) to initialize the 2TB drive.  The system replicated the system software in the hidden partitions, however it did not replicate DATAVOLUME as the drives were different sized.  After this I was able to boot from the 2TB drive with all other drives removed.  I booted the system, inserted the 2nd 2TB drive in bay 2, and proceeded to do a full system rebuild on the 2 - 2TB drives in bays 1/2 (rebuilding the DATAVOLUME), then recreate my shares, then fully restore the data from the 1TB drives to the newly rebuilt system and the docking station as I mentioned above.  In conducting the rebuild, the users/groups/passwords were intact, only the shares had to be rebuilt and remapped to the existing users.

I’m not sure, however I am guessing my problems were primarily due to using 2 different sized drives when I added the EXT VOLUME in bays 3/4.  If you are using the same size drives, you may not run into this same issue.  You may want to contact Customer Support for clarification.  Some basics to recommend:

1 - If you run into a problem showing failed drives however you can still access your shares, back up ALL data prior to rebooting (I was kicking myself for some time after I rebooted).

2 - if you lose access to your shares, remove a drive, put it away, and work primarily on just a single drive until you can access your data.  Better yet, make an image and work from the image.  This prevents you from corrupting your mirror in the process of working on the drive.

3 - Professional data recovery runs about $1000 for a 1TB raid 1 drive.  The data is still intact, but time consuming to recover and can be done yourself  on a RAID 1 configuration without too many issues.

Good luck!

1 Like

Thanks, demillerusn, for your insights.  I’m sorry to hear about the wealth of trouble you’ve been through!  Without your experiences I would likely run into severe problems of my own!

Actually my new disks are 2TB and the good old DATAVOLUME is showing “failed”, Fortunately I’m copying data now and has kept away from Submit buttons and reboot orders :-).

I’ve tried to get clear answers from WD Tech support several times, but they’ve been unable to say “yes” or “no”. But some postings in this forums indicated it was possible, and I decided to try. After all  it is two separete volumes and a full TB of valuable safe storage :-).  Have you found any documentation where this is clearly explained?

So - you never succeeded in getting both volumes up simultaneously?

Anyway - this is probably not a bug, but a “feature”.  Some very strange character in WD has decided that this is the way to do things - regardless of the vehemently apparent stupidity in letting configuration of one independant RAID volume impact another.

br

Sounds like what I went through, glad I helped stop prior to the reboot.  I would submit that WD has some more work to do in the system software in this area.  I agree, there is no reason you should not be able to establish two independent mirrors regardless of drive size.  Also you should be able to add a second mirror without impacting the primary mirror.  Unfortunately the documentation doesn’t provide sufficient detail to cover this. 

I have not gone back to adding the 1TB drives back in the system and trying to get both up simultaneously, I was going to instead use the 1TB drives to upgrade my DVR…

WD - anyone?!!

This is something that you would have to contact WD about in order to get verification.  Support doesn’t monitor these boards.

To Contact WD for Technical Support
http://support.wdc.com/contact/index.asp?lang=en

1 Like

Update:   I now have two separate RAID1 Volumes running Good.

DataVolume: 2 x 2TB

ExtendVolume: 2 x 1TB.

Originally I had only DataVolume: 2 x 1TB in RAID1.  Running out of space, I got two new 2TB disk. However I did not succeed in getting the up and running.  I tried repeadtly, but each time ShareSpace choked around 98% into Resync.  It appears creating the filesystem triggers an error.

I then moved the 2TB disk to DataVolume (using procedure described by demillerusn above).  No problem creating volume.  I installed the two old disks in slot 3 and 4.  No problem creating ExtendVolume either.

I am pretty sure this must be related to a bug, a very time consuming one to be bit by!

Anyway: I can confirm that two separate RAID1 volumes consisting of disks not of same size actually works!  Just make sure you have a backup/copy of all data before starting.

wdcDualRaid.jpg

I think you have to set “Extend Span” to Manual. Go to advanced settings, click on System, then Advanced. By default it’s set to “Auto Extend” which means when you put in additional drives it’ll try and extend the volume and it probably fails because the drives are different sizes.

Hi Mick_T -  I have no spans, but two separate RAID1 mirror volumes, obe named “DataVolume” and another named “ExtendVolume”. These names are system created.  And all is ok.

Originally I had only DataVolume: 2 x 1TB in RAID1.  Running out of space, I got two new 2TB disk. However I did not succeed in getting the up and running.  I tried repeadtly, but each time ShareSpace choked around 98% into Resync.  It appears creating the filesystem triggers an error.

This is exactly what I’m running into. It’s syncing the new RAID on the new disks, but when it gets about 4-5 hours in (maybe about 75-90%?) it reboots.

I will try your approach - thanks for sharing! Will the other disks just work when they’re plugged back in or will they need to be reinitialised?

I have managed to add the 2x2TB disks to my 2x1TB ShareSpace by:

  1. removing them all

  2. adding in just one 2TB disk and letting the ShareSpace reset itself using that disk as the DataVolume

  3. add back in the 2TB disk and setting up a mirror

  4. add back one of the 1TB disks, logging in as root, manually mounting it (mdadm and lvm “fun”) and copying all the data to the 2TB Datavolume (which took 20 hours)

  5. add in the other 1TB disk and setting up the 2x1TB disks as ExtendedVolume mirror

Thanks to all the previous posters for their advice and war stories.