Copy to USB stops out at 45mb

I have a My cloud home - with the latest firmware.

The issue I have is when I use either the web app or mobile app to use the Copy to USB function it’s starts copying and the mb count goes up etc and as soon as it hits about 45mb I get a “something went wrong” error. It used to be ok.
I have unplugged - rebooted - shut down - still get the same. I have checked the external drive for errors and it’s ok
I tried another External USB and tried to copy just one file - that worked fine. So I tried to copy a second file and now I get the error again and now the second drive is getting the same error as the first.
So I have about 80% of files backed up and have added another 20% of new items that I thought I could just run the Copy to USB and I’ll have a full backup again.

The only other way to to connect the external dive to my PC and copy and paste - but that says it’s take more than 1 day - which is not practical

Any help please :slight_smile:

It is most likely NOT the firmware 9.60.111. You didn’t mention if you were using an external USB HDD and whether it is a powered HDD with its own power supply. Often home user will overload the USB port by drawing too much power and the port will shut down after initial copy.

Try with a flash drive or a USB-SSD drive and see if you still have the same problem. If that works, try it with a powered USB HDD.