Constant disk activity-why?

Folks, I just purchased an 8TB MyCloud EX2. I’ve copied a lot of content to it for backing up.
The blue disk lights are constantly blinking even when I am not accessing the drive through my computer or any network service and I am unsure why.

I don’t have the DNLA or iTunes server on.
I disconnected the ethernet port to see if that would solve the issue.
I restarted my Mac.

Any ideas?

If the data was copied to a share other than Smartware or Time Machine, then thumbnails are being created.
If you do not want thumbnails created, disable Cloud Service.
If you want Cloud Service, but no thumbnails, put your data in the Smartware or Time Machine share so thumbnails are not created. Keep in mind that the My Cloud Mobile and and MyCloud.com cannot view data inside the backup shares.

Turning off cloud service solved the problem. However it had been creating thumbnails for at least two days. I am surprised it takes that long. I wonder why.

In any case at least the light stopped flashing for now until I fully learn this device and take advantage of cloud service.

Wait, wait, can you return the product? It would be way nicer for you to get EX2 Ultra than EX2: almost twice the performance. But, if you can’t, how many terabytes of files do you have? It might take a lot of time if there is a lot of data and EX2 has a little bit slow performance. Have you updated it to the latest firmware too?

Edit: Just saw that the problem was solved, but if you can return the product and change it to EX2 Ultra, that would be way better as they are pretty much the same price.

Hmmm. Thanks for the heads up. You’re right. I just bought it and can return it. What’s strange is that the EX2 is more expensive where I bought it (Fry’s) and on Amazon than the EX2 Ultra which you say is better. That doesn’t add up.

I have to check more, but if it is better, I’d certainly return the EX2 and get the EX2 Ultra.

I’m sure of this. I’m not sure about the price though. " The Ultra offers a slightly faster 1.3GHz dual-core processor and twice as much RAM, bumping up to 1GB."(Cnet) http://www.cnet.com/products/wd-my-cloud-ex2-ultra/ Also, based on WD website itself, http://www.wdc.com/en/products/nas/expert/ . EX2 has 1.2GHz single core CPU with 512MB of RAM while EX2 Ultra has 1.3GHz dual core CPU with 1024MB of RAM. Consider WD EX2 Ultra as the second generation, that is why they can make it cheaper, but still faster than EX2. I would definitely return it to get WD EX2 Ultra, it’s comparable to WD EX2100.

Edit: you can search more on it as well, or wait for others to help confirming, but I would say that EX2 Ultra is definitely better.

I ordered it and thanks for the information. I wouldn’t have known otherwise. One thing I don’t understand though is why it takes soooooooo long to copy files from my Mac to the NAS. It took almost three days for 2.6 TB over Gigabit Ethernet on all devices.

Perhaps I am impatient. I work with thunderbolt everyday and Gigabit Ethernet, but I’ve never seen modern tech over gigabit ethernet move that slow.

I hope it doesn’t take that long to copy what’s on my EX2 to my EX2 Ultra when I get it so I can return the EX2.

From what I think, it will only copy at about the same speed as the speed depends on the slowest one. But I’m sure that after getting rid of EX2, EX2 Ultra will allow you to do file transfer way faster.

it basically depends on types of files you copy.

I did copy say 2tb of files only 60 files each 45-70gb each ranging. UHD 4K 10 bit .

It took me 4hr-6hrs on each 1tb of copy which i made.

Also it depends on the type of raid you have. If you have 8tb but the dasboard says 4tb Every file copying being replicated to other drive. so as the delay in 2+ days.

My WD MyCloud EX4 is also thrashing away at all four drives 24x7. I have turned off every service that I can find, it takes a full day to reboot. It is essentially inaccessible on the network, shares timing out. I have replaced all four drives, same problem. Only one drive in the unit give the same issue, basically unusable.

I recently moved my NAS to another room, which introduced a powerline network to the path from it to my router/switch/WAP. After this the NAS started constant activity which it never did before the move.

After some tinkering, I found that the Powerline adapter was set to a “power save” mode which put it to sleep if no activity from the ethernet. On de-activating this mode the NAS settled down again within an hour or two…

…my guess is that there’s something which the NAS does “upon network connect” which was repeating everytime the powerline adapter went to sleep and woke. The NAS itself was probably waking it up (to get NTP or something), or perhaps it woke when a PCs went looking for the NAS?

BTW I turned off the power saving mode on the powerline adapter near the router too (I now only use that setting in the office where i don’t have anything which should need network unless I’m in there and active). The adapters were TP_Link, and are good otherwise.