Configuration of SMTP server

I was told by WD support engineer to post here as he is unable to help me with my issue, and said that the engineers montior these forums and this is the only way of support…

I’m trying to monitor my EX2, via email which seemed to me as a basic task, but unfortunately showed to be bigger issue than I expected. The problem is, that due to security my NAS is behind proxy and FW, so it cannot connect directly to SMTP server saved in /etc/smtp.conf file:

 It is possible to modify SMTP configuration via SSH, but after the reboot this modified config does not persist… I can make workarounds to make this working, but I would preffer to have the option of configuration own SMTP server especially for user who are not capable of such workarounds.

Is it possible to implement such a basic option?

Welcome to the Community.

Most SSH modifications tend to be reverted after a device reboot. Some advanced users have worked on scripts addressing this behavior though.

I probably expressed myself in a wrong way. I’d prefer not to make any workarounds and to have this option directly in the webpage configuration.

If you have balls of steal, you may want to also edit /usr/local/modules/etc/smtp.conf as I believe that is what is used to overwrite the settings on reboot.

I tried to edit this one but apparently sshd has no permission to do so… Any ideas?

Could be a number of things. I dont have access to my NAS right now but will check this out in the AM. I trust you tried “sudo vi smtp.conf” ?? Also, enter “whoami” and see if you are root. Check the perms on the file, if the file perms are flatlined, you may need to “sudo chmod 755 smtp.conf”. I will test this tomorrow on our WD NAS…

Well, it looks like /usr/local/modules gets mounted as a read only file system. Unless you want to dig into the bowls of the system and change that, I think you are out of luck.I don’t recommend that.

Hello there.
Port 58705 seems to be no longer open for smtp to In newer Versions of wd my cloud it should work again but when for what ever reason you want to use the old firmware you can try a gmail Account. Connect to the wd my cloud via ssh and change the Account to the smtp.conf like that:

With this changes sending E-Mails ist working again with the old firmware. The problem is that the changes in the smtp.conf are not persistant. After the next reboot the changes are gone. Any ideas how I can fix this?