Client Computer shows offline in Dashboard

I’ve recently installed the connector software on a new Windows 7 Pro client laptop.  Initial backup to the Sentinel server went fine.   Since then, the computer always shows up as offline, preventing Dashboard from doing any additional backups.  Trying to sign in from the client with launchpad results in a message saying the server is offline.  I can see the backup server from the client with explorer and can remote login to the server just fine.  I’ve tried uninstalling and reinstalling on the client and after the first backup, same thing.  I’ve rebooted, no change.  I am running the UEFI hotfix.  What could the problem be? 

Check out this thread:

http://community.wdc.com/t5/WD-Sentinel-DX4000/Helpful-Link-for-Troubleshooting-Connector-Installation-Issues/td-p/541638

All other clienst show properly?

You did not install the BPA tool?

All of windows up-dates are applied to the server.

3rd party AV/firewall?

I’m seeing the same thing.  I have 4 units installed.  I have also installed the UFI hotfix.  In one install, of 22 clients installed, 8 went offline.  The fix is simple, uninstall and reinstall but it’s a PIA.  All were getting backups until they dropped off.  Why did they drop off?  In another, of 15 clients 5 went offline.  BTW, I don’t have any installations w/o the UFI so I don’t know if the problem occurs under those conditions.

Ok, it finally hit me what is going on :slight_smile:

When you install the uEFI hot fix it updates the connector in the background.  The boxes require a reboot.  If no one was at the PC when it popped up the messages, or who ever saw the pop up had no clue.

In any case, a reboot of the client should fix it.

Still no luck.

All of my other computers are successfully showing online.  This particular client is a 64 bit Windows 7 Pro client – just like some others.

Dashboard says the server software is up to date (and I’ve applied the efi hotfix).

Following the instructions in the guide for debugging client install issues, I did the following:

  • removed the offline client from the list of backed up computers on the server

  • I uninstalled the connecter software on the client

  • I reinstalled the connector software on the client

  • I manually installed the efi hotfix on the client (I got this from down deep in the windows server folder on the server kb2781278-amd64.msp).

  • At this point, the client shows up online in the dashboard. 

  • I reboot the client

–> client shows up offline again.

What am I doing wrong?

I don’t know about the BPA tool - it looked like it was for Exchange issues.

You should not have to dig down to manually install the uefi hotfix on the client.  When you install it on the server it replaces the connectore version. 

At this time I recomend uninstall connector, reboot, surf to servername/connect and run the connector setup.

I tried installing efi hotfix manually cuz one of the troubleshooting guides recommended I try that. Since then I have uninstalled the connector software on the client, reinstalled it and the client backs up just fine until I reboot the client.  After the reboot, the client appears offline in the dashboard and cannot be backed up.  To get a backup, I have to uninstall and reinstall the connector software after a reboot. 

Any ideas?

don’t reboot ?  JK

After a reboot, go to services.msc and see if the windows server stuff is started.  There is one on mine, “Initialization” that is not started, so I guess that one does not matter :slight_smile:

I’m still having issues with users going off line when a computer is physically removed and reattached to the network.  I have a total of 4 boxes and about 60 users installed.  Three users keep going offline.  All 4 DX4000 do have the uefi patch installed.  All three uses that drop off are Lenovo e530 win7-64 bit units.  I have other identical notebooks that are not having a problem.  The difference is, the three that have the problem are often removed from the network and taken home.  It seems that once the notebook is detached from the network it will not reconnect to the DX-4000 even after a reboot.  If it remains connected to the network, the backup will work until the computer is removed and then when reconnected to the network, it will not log into the DX4000 and asks if I want to log in in “offline” mode.

The “fix” is to uninstall/reinstall the connector but that gets old both for me and the customer.  All patches are up to date on both the DX-4000 and the client computers.

When one of them is not working can you ping the dx by name?

do these have a different firewall?

yes I can ping it and I can even access the shared folders but I cannot “log in” or do backup since it is “off line”.  I have further refined the cause of the problem.

It only happens for users of notebook computers to take their computers home with them.  It further seems to only be a problem if the user turns his computer on when removed and connects to another network (like a home network) and then returns and connects to the work network.  Even a reboot after that will still show offline.  I have not proved that theory yet but I know that not all removed notebooks have a problem reconnecting and I know when I’ve asked some of them, they didn’t use it at home.

Unfortunately, it’s the important people who use their computer away from the network. 

Service activation did the trick.  Some of the services (Windows Server) needed to do backup were not started at boot on this computer. When manually started, the computer could be seen as online by the dashboard and backed up normally.  I suspect the computer in question has a timing issue in a chain of dependent services – some service did not start fast enough at boot.  This particular machine is a laptop which has to be backed up manually since it is taken home every night so the user is comfortable manually activating the services before backing up.  I suspect the user could fiddle with the recovery options on the service properties and eliminate the need to activate services manually but they are satisfied with what they have.

It may be the same service issue also being discussed in this thread.  If they put the computer to sleep and wake it at work, the services are prob not started.

A reboot on the worek network should “fix” it.  If not check those Windows Server services

That is the problem and rebooting does not fix it.

There is a service named “Windows Server Client Computer Backup Provider Service” which was set to automatic but was not started.  Once I started it, I was able to start launchpad and start the backup.  That is at least a much easier fix than uninstall/reinstall.

So I guess the next question is, “what makes it stop and how do we prevent that?”

I’ll gather some more information and report back.

can you try setting that service to automatic (delayed start) ?

I have set the service to delayed start but that doesn’t seem to solve the problem.  When the service is not started, launchpad will not log in which it does at the start.  Even when the service is started subsequently, the backup does work but the computer still shows off line in the console.

BTW, does the client computer create a log entry in the event log to show a successful backup?  I’ve not been able to find one.

In the event viewer on down is aplication something.  Windows server is below that.  Backups are in there.

what AV do you have?  if it is other than ms, tryt disabling it, reboot for giggles