Another Windows 10 client issue [SOLVED]

Hello All,

I had a decent 6-month run with most of the Windows 10 machines and the Sentinel, but a few days ago I have 1 Windows 10 client that can’t connect to the Sentinel Backup service…It can see the shares and connect to the dashboard no problem, but it will not start the Windows Server backup service, nor will it let me re-install the connector software using wdsentinel/connect from a web browser…I’ve disabled the AV and checked other services on the client, and everything “should” be ok, but it won’t connect. I rdp’ed into the Sentinel and tried to run a manual backup on the client and it just gives an error (see attached image)

Should I just manually uninstall and re-install the connector software on the client machine? Thanks for any help here, going to have to start looking for a replacement to the Sentinel in the next few months…

If your win10 box did an upgrade you may want to uninstall/reinstall the connector
If that still fails look in the event log for errors when you try to manually start the service(s)

thanks for responding gramps…quick question: do I need to remove the client from the WD sentinel dashboard as well as uninstalling the connector software - then re-join through the dashboard? many thanks once again

No, do not remove from the dashboard and when you run connect again it will say name exists, just hit next

thanks - I’ll give it a try when I resume work on the client machine and report back.

well, I uninstalled the connector software on the client computer, then tried reinstalling the connector and it gave the same error I mentioned in my last few replies…So, I renamed the computer, rebooted, and tried re-installing the connector, and while the setup process starts, it gets to 99% completion, then rolls back and says the connector quit because of an unexpected error…I have never seen this occur in the 4+ years I’ve been using the DX4000.

I disabled the A/V and Firewall on the client machine, made sure the correct win services were active, and it will still not install the connector on the client - after 3 attempts.


Is this an upgrade from win7?
https://support.microsoft.com/en-us/kb/2520547

If it is a 3rd party av/symant3ec sometimes disabling does not help. It has to be uninstalled

Hi Gramps,

The problem is now on 2 PCs - each were upgraded to Windows 10 from Windows 8.1

Each PC runs latest version of Norton Internet Security - and I have fully disabled while performing work on the machines.

The Connector (and backup service) worked flawlessly without any issues for months, but about a month ago just stopped connecting to the Sentinel backup service - and now, I cannot re-install the connector software on either PC.

You either get the error as seen in the image in my first post in this thread, or in the case of 1 of the PC, it will start the connector install, get to 99% completion, then roll back saying “cannot install connector due to unspecified error” - and then quits.

I have 6 other PCs that were upgraded just as the ones above - that are the same model with identical hardware and OS/Software installed - and they work with the connector software and Sentinel backup service fine.

If the connector is still on one of them look at services.msc and make sure the windows server essentials backup service is running
On the one that will not install did it have media center? Start the service from the above link?

Neither PC had media center installed…

I’ve uninstalled the connector software in each PC that wouldn’t connect, and now, neither workstation will reinstall the connector software - this is with A/V disabled, and I’ve double-checked that the necessary services are on and running.

Does anyone have a solution to this?

Absolutely maddening, as now I’ll have to backup each PC manually…

Here is the screen that appears after hitting the first “next” button on the connector install:

Well that error is so common they have a fixit for it. Have you tried it?
https://support.microsoft.com/en-us/kb/2723674

Yes, I tired that fix about an hour ago, rebooted the machine, and it is the same error as before.

here is the latest connector install log:

[06/27/2016 11:11:37 2028] wmain: Start of Computerconnector
[06/27/2016 11:11:37 2028] wmain: Calling Computerconnector::ShowWizard()
[06/27/2016 11:11:37 2028] CComputerconnector::ShowWizard: Initializing common controls
[06/27/2016 11:11:37 2028] CComputerconnector::ShowWizard: Done initializing common controls
[06/27/2016 11:11:37 2028] Displaying the wizard
[06/27/2016 11:11:37 2028] CComputerconnector::ConnecttingDlgProc: IDD_CONNECTING Page Initialization
[06/27/2016 11:11:37 2fe0] GlobalData::Initialize (IP, 65510, C:\Users\Webmaster\Downloads\ComputerConnector (IP).exe, 1033)
[06/27/2016 11:11:37 2fe0] ExpandEnvironmentStrings return (C:\WINDOWS\Temp\Client Deployment Files)
[06/27/2016 11:11:37 2fe0] CComputerconnector::Run: Running Task: Id=1 Description=Downloads the Setup.cab file
[06/27/2016 11:11:37 2fe0] NetworkUtil::DownloadFile (HTTP://IP:65510/Connect/default.aspx?Get=Setup.cab&64bit=1&LanguageId=1033, C:\Users\WEBMAS~1\AppData\Local\Temp\Setup.cab)
[06/27/2016 11:11:37 2fe0] NetworkUtil::DownloadFile - Create directory [C:\Users\WEBMAS~1\AppData\Local\Temp] if not exist.
[06/27/2016 11:11:37 2fe0] NetworkUtil::_WinInetDownloadFile (HTTP://IP:65510/Connect/default.aspx?Get=Setup.cab&64bit=1&LanguageId=1033, C:\Users\WEBMAS~1\AppData\Local\Temp\Setup.cab)
[06/27/2016 11:11:48 2fe0] ExtractCabinet: Extract (C:\Users\WEBMAS~1\AppData\Local\Temp\Setup.cab, C:\WINDOWS\Temp\Client Deployment Files)
[06/27/2016 11:11:48 2fe0] SetRegValue [C:\WINDOWS\Temp\Client Deployment Files].
[06/27/2016 11:11:48 2fe0] Deleting [C:\Users\WEBMAS~1\AppData\Local\Temp\Setup.cab].
[06/27/2016 11:11:48 2fe0] RunShellExecute: ShellExecute [C:\WINDOWS\Temp\Client Deployment Files\CSetup.exe] with parameters [(null)]
[06/27/2016 11:11:48 2fe0] CSetup::Run: Waiting upto 30secs for Sync Event to be signaled
[06/27/2016 11:11:48 2fe0] CComputerconnector::Run: WaitForSingleObject RetVal = 0
[06/27/2016 11:11:48 2028] wmain: End of Computerconnector: hr=0x0

which error now? Still says pending reboot or goes through and then undo changes?

It is giving the same error as before when you try installing the launchpad client, after multiple reboots:

Does WD still provide phone support on these things? I’ve spent about 10+ hours trying to get the connector software re-installed on these 2 Windows 10 PCs…Each PC had run the client software for many months without incident.

well, I rebooted the Sentinel itself, and now we are getting a new error - when I run the connector setup, it actually gets past the first 2 setup screens - but when it gets to the 3rd screen - where it asks you for the admin password, I noticed it has renamed the name of the sentinel (it should just be “wdsentinel” - not the “technical preview”…etc.):

and it crashes right when you hit the next button - regardless of what password is entered:

here is the log:

[9440] 160627.120920.0427: ClientSetup: Start of ClientDeploy
[9440] 160627.120920.0896: General: Initializing…C:\WINDOWS\Temp\Client Deployment Files\ClientDeploy.exe
[9440] 160627.120920.1052: ClientSetup: Loading Wizard Data
[9440] 160627.120920.1208: ClientSetup: Current DeploymentStatus=Failed
[9440] 160627.120920.2459: ClientSetup: Showing the Client Deployment Wizard
[9440] 160627.120920.3709: ClientSetup: Adding Server Info data in the Product Registry
[9440] 160627.120920.3865: ClientSetup: Set the Deployment Sync Event
[9620] 160627.120926.3602: ClientSetup: Running ValidateUser Tasks at WizardPage HomeServerCred
[9620] 160627.120926.3602: ClientSetup: Entering ConnectorWizardForm.RunTasks
[9620] 160627.120926.3602: ClientSetup: Running Task with Id=ClientDeploy.ValidateUser
[9620] 160627.120926.3602: ClientSetup: Entering ValidateUserTask.Run
[9620] 160627.120926.3602: ClientSetup: Install root cert to local trusted store
[9620] 160627.120926.3756: ClientSetup: Validating User
[9620] 160627.120926.3756: ClientSetup: Call MachineIdentityManager.GetMachineStatus
[9620] 160627.120926.3756: General: Failed to open IDENTITY registry key.
[9620] 160627.120926.3756: General: Failed to open IDENTITY registry key.
[9620] 160627.120926.3756: General: Failed to open IDENTITY registry key.
[9620] 160627.120926.3756: General: Failed to open IDENTITY registry key.
[9620] 160627.120926.3756: General: Failed to open IDENTITY registry key.
[9620] 160627.120926.3756: IDENTITY: Couldn’t load CertNative.dll from C:\Program Files\Windows Server\Bin\CertNative.dll. Last Error = (126)
[9440] 160627.120926.3913: ClientSetup: !!!FATAL!!! Unhandled Exception: System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. —> Microsoft.WindowsServerSolutions.ClientSetup.ClientSetupException: Unexpected Error occured: DeploymentStage=InstallingPreRequistes —> System.TypeInitializationException: The type initializer for ‘NativeMethods’ threw an exception. —> System.IO.FileNotFoundException: C:\Program Files\Windows Server\Bin\CertNative.dll —> System.ComponentModel.Win32Exception: The specified module could not be found
— End of inner exception stack trace —
at Microsoft.WindowsServerSolutions.Certificates.CertManaged.NativeMethods.LoadCertNativeDll()
at Microsoft.WindowsServerSolutions.Certificates.CertManaged.NativeMethods…cctor()
— End of inner exception stack trace —
at Microsoft.WindowsServerSolutions.Certificates.CertManaged.NativeMethods.IdnToAscii(UInt32 dwFlags, String UnicodeCharStr, Int32 cchUnicodeChar, StringBuilder ASCIICharStr, Int32 cchASCIIChar)
at Microsoft.WindowsServerSolutions.Certificates.CertManaged.PunyEncodedFQDN(String FQDN)
at Microsoft.WindowsServerSolutions.Devices.Identity.MachineIdentityManager.GetCertServiceClient(String serverName)
at Microsoft.WindowsServerSolutions.Devices.Identity.MachineIdentityManager.GetMachineStatus(String serverName, String userName, String password, String machineName, Boolean& isAdmin)
at Microsoft.WindowsServerSolutions.ClientSetup.ClientDeploy.ValidateUserTask.Run(WizData data)
at Microsoft.WindowsServerSolutions.ClientSetup.ClientDeploy.ConnectorWizardForm.RunTasks(Object sender, DoWorkEventArgs workEventArgs)
at Microsoft.WindowsServerSolutions.ClientSetup.ClientDeploy.ConnectorWizardForm.<m_wizardPageHomeServerCred_PageValidating>b__0(Object worker, DoWorkEventArgs workEventArgs)
at System.ComponentModel.BackgroundWorker.OnDoWork(DoWorkEventArgs e)
at System.ComponentModel.BackgroundWorker.WorkerThreadStart(Object argument)
— End of inner exception stack trace —
at Microsoft.WindowsServerSolutions.ClientSetup.ClientDeploy.ConnectorWizardForm.<>c__DisplayClass2.<m_wizardPageHomeServerCred_PageValidating>b__1(Object worker, RunWorkerCompletedEventArgs completedEventArgs)
at System.ComponentModel.BackgroundWorker.OnRunWorkerCompleted(RunWorkerCompletedEventArgs e)
— End of inner exception stack trace —
at System.RuntimeMethodHandle.InvokeMethod(Object target, Object arguments, Signature sig, Boolean constructor)
at System.Reflection.RuntimeMethodInfo.UnsafeInvokeInternal(Object obj, Object parameters, Object arguments)
at System.Delegate.DynamicInvokeImpl(Object args)
at System.Windows.Forms.Control.InvokeMarshaledCallbackDo(ThreadMethodEntry tme)
at System.Windows.Forms.Control.InvokeMarshaledCallbackHelper(Object obj)
at System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)
at System.Windows.Forms.Control.InvokeMarshaledCallback(ThreadMethodEntry tme)
at System.Windows.Forms.Control.InvokeMarshaledCallbacks()
at System.Windows.Forms.Control.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.DebuggableCallback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)
at System.Windows.Forms.UnsafeNativeMethods.DispatchMessageW(MSG& msg)
at System.Windows.Forms.Application.ComponentManager.System.Windows.Forms.UnsafeNativeMethods.IMsoComponentManager.FPushMessageLoop(IntPtr dwComponentID, Int32 reason, Int32 pvLoopData)
at System.Windows.Forms.Application.ThreadContext.RunMessageLoopInner(Int32 reason, ApplicationContext context)
at System.Windows.Forms.Application.ThreadContext.RunMessageLoop(Int32 reason, ApplicationContext context)
at System.Windows.Forms.Form.ShowDialog(IWin32Window owner)
at Microsoft.WindowsServerSolutions.ClientSetup.ClientDeploy.Program.Main()

You are running connect from wdsentinel/connect ??
You have not had this machine attached to any other Essentials server?

Guess I thinking this was a DX4000, is it a DS5100/6100 With 2012R2?

Your first screens look like a DX, but this last one looks like a DS?

yes - I have tried wdsentinel/connect from a browser, and also tried manually launching the connector executable.

there has been 1 DX4000 here, and only 1. It is running the default OS that shipped with the Sentinel - 2008 server storage edition.

just spoke to a level 1 techie @ WD, and he’s going to have a level 2 tech give me a call back later, or perhaps tomorrow. The level 1 guy seems to think it is a registry issue.