Can't map My Cloud Home as a network drive

I’ve just got a new PC and I Can’t map My Cloud Home as a network drive.
I did this on my old PC, so I could send files straight to the drive to be shared with my TV.
My new PC sees the shared folders, but without the network drive facility I can’t download stuff direct to the correct folder.
Has anyone got any ideas.
My new pc runs win 11, the same as my old PC, My Cloud Home is v04.05.00-342.


You own a WDMYCLOUD not a My Cloud Home! The image below shows how I would map mine. I right click on a share. I now have my MYCLOUD 1st generation set up on my home network.


@pebbleridge Please note that the My Cloud Home is an entirely different device than the My Cloud line of devices. What you have is a first generation single bay/single drive My Cloud if it is running the V4.x firmware (per the My Cloud Dashboard).

First step, if the My Cloud is operating properly (blue front LED) is to check the SMB/CIFS setting on the new PC (assume Windows PC). You may have to enable SMB1.0 since Microsoft typically disables that setting in Windows 10 and later.

Enable SMB 1.0 CIFS File Sharing Support for My Cloud, My Cloud Home, My Passport Wireless and Legacy NAS Products

If one does not want to enable SMB1.0 on their Windows PC, one can still map a My Cloud network Share using the My Cloud’s IP address.

How to Map a My Cloud Network Drive on Windows
How to Map a My Cloud Network Drive on Windows
How to Map a WD Network Drive on Windows 11 and Windows 10
How to Map a My Cloud and My Cloud Home Network Drive on macOS

@Bennor Many thanks, you’ve cracked it.
SMB1.0 was not enabled, I followed the instructions on the link in your message and BINGO it works.
I have now got the access to my Drive that I wanted.

I wonder if your expertise extends to general mapping issues?
I’m also trying to map a drive on my old pc (on the same network) the pc appears on the network when I try to map a new network drive, but when I click it I get no drives to select, do you have any ideas?

Thanks again,

Thanks for your reply, I don’t think my WD My Cloud is connected to the Internet, so I think I am safe on that issue, but it is getting on a bit so I might put a new one on my Christmas List.

Can you post a screen shot of the error or issue you are having on the “old PC”. It is not clear what “when I click it I get no drives to select” means. Click on what? The My Cloud or something else?

Here’s a screenshot.
In the Browse for a folder screen, I select Hewletpackard, and the wheel just spins, but after waiting quite a while I got the Network Error message.

To share a folder on a Windows PC you need to enable file/print sharing on that PC then set the permissions for the folder you want to share. Otherwise that PC will reject any attempts to access folders on it’s hard drive. There are various how-to guides out there that explain how to do so. For example:

Hi again,
Thanks for all your help, but I still can’t manage to share correctly.
It keeps asking me for a password, I’ve tried every password it might be, and I’m locked out now.
I’ve given up and plan to copy my files to a portable hard drive and move them that way.
Thanks again for all your help at least I can see my NAS now.

I’ve just come up with a better idea.
I can access the NAS from both machines, so I’m copying the files I want to transfer from my old PC to the NAS then moving them from the NAS to my new PC.
One more step but it’s working.

Generally when sharing a folder/directory on a separate Windows PC and you get asked for a user/password you use the username and password that one logs into on that specific separate PC. If there are multiple accounts on that separate PC then one should check which account the shared folder is assigned to and use that account’s username and password.

But yes, if both PC’s have access to the My Cloud one could simply copy the data from the one PC to the My Cloud and from the My Cloud to the second PC.