Can't input special characters in My Cloud user password

I have one 2TB and 3TB My Cloud with 2.21.126 firmware.
The problem is that on the 3TB version I can’t set a password with special characters :frowning: (I remember I could have special chars in the past on that device)

On the 2TB version with THE SAME firmware I can have passwords witch special characters.

What is going on???


Have you actually tried changing the password on the 2TB device, or is it using a password established on an earlier version of firmware?

It may be that the limitation is only being imposed by the password change routine.

Yesterday I tried to change password on 2TB machine and it went ok with special chars (from my old one to my new one)

About one month ago I wanted to change my password on 3TB for longer one. Old password had special char. I also couldn’t change it for special chars so I left it.

When yesterday I’ve changed the password with special chars on 2TB machine I thought that maybe it was firmware issue so I can change it now on 3TB machine, but not. I still can’t change to special chars on 3TB. Both machines have the same, latest firmware…

I don’t know if it matters but also HOME screen on both machines look differently when I log in. On the 3TB machine I have “network activity” (which is not present on 2TB) and on 2TB machine I have "scanning " which is not shown on 3TB machine. It looks like they were slightly different one from other.

Are you SURE they have the same firmware? Sounds like one is a Gen1 and the other is a Gen2, perhaps?

I wondered whether one was a simple MyCloud, and the other a Mirror or higher.

Both are MyCloud one disk devices. They look the same and has the same name.
Because I have them in two different locations I can’t check firmware number exactly but I remember that both of them have the newest from december 2016 so I assumed that they have the same firmware but I’m not 100% sure…
Thanks for your input!

There’s two generations of the My Cloud. They look pretty much identical in appearance, but run different software. The Gen 2 run a 2.x.x version. The Gen 1 (older units) run 4.x.x.

OK. I have firmware data from both devices:

2TB - 04.04.05-10
3TB - 2.21.126

So it looks like two different Gens :frowning:

on the Gen1 I can have special chars in password on Gen2 I cannot. That’s frustrating!
If I wanted two different devices I wouldn’t buy THE SAME brand and model :frowning:

I have been using many NAS disk since last 10 years but WD Cloud is the worst of them all.
Unbelievable slow performance in Gigabit wired network, lack of simple config options in UI like indexing on/off and now I need to have two different password on both machines or resign from my favorite password :frowning:

Thanks for your help guys!

We feel your pain. We moaned bitterly at WD when they silently released the Gen2, without any announcement that it was a different product (they still insist it’s the same product when clearly it isn’t; different hardware, very different firmware). That stubborn decision has caused a lot of problems for users, WD support, and the ‘unpaid support’ on this forum.

But hey; the packaging is a different size! It’s obvious it’s a different model…

So there is no way to input special chars in Gen2 password?