Can't get WebDAV to work


Im trying to find a way to stream movies to Kodi when I am away from home. My latest atempt has been with WebDAV but even though I have enabled WebDAV in the network settings and the shares, forwarded ports 4443 and 8080, I still  can’t access the NAS. Have tried using both Kodi and CarotDAV. Also tried both http://<my_ip>:4443/Public and https://<my_ip>:8080/Public. 

This is the test output from CarotDAV:

vid Rei.Fs.Webdav.WebdavFs.GetResponse(HttpWebRequest request, Boolean notreqstream)
vid Rei.Fs.Webdav.WebdavFs.GetResourceOptions(Uri target)
vid Rei.Fs.Webdav.ConnectionTestForm.Check()

You’re missing part of the URL.   

I think it’s supposed to be something like


The URLs look correct (there is no dav in there for the MCM), but I think you’ve got the http and https swapped over. 8080 is for http and 4443 is for https.

 So it should just be http://:8080/Public or https://:4443/Public.

Also it’s perhaps worth enabling the port forwarding on the MCM itself if you have uPNP enabled on your router, as it’s a bit easier than setting the rules up there.

One other thing to confirm is that the username and password you are using for the log-in (one of the accounts set up on the MCM) are correct, although of course in the above example that’s not needed as the access is public. Also ensure that you use the correct case for the URL, as the share names etc are case sensitive.

Oh yes, I mistakenly swapped the http and https ports in my post. I think the problem was that the NAS couldn’t connect to the Internet for some reason? I realized it when I looked at the cloud access tab and it said it wasn’t connected. I have no idea why it didn’t have internet but after some disconnect, reconnect of my router (which I did for another reason) it was up and running again and I was actually able to connect to it using CarotDav, however I got some certificate issue which I had to ignore to connect. But that did not work on Kodi where it just said “Unable to connect to device”… So I’m still stuck :confused:

CarotDav returned this output when I connected to the MCM:

server certificate is not issued by trusted authority.

server certificate is not issued for the connected server.

server Certificate is still available.

Thank you for your help! It is greatly appreciated! :slight_smile:

That’s using port 4443 (https)?

Try using port 8080 (http) as that shouldn’t need any security certification.