Can't get Passport to back up on new computer

I’ve had My Passport for a while and it seemed to be backing up fine on my last laptop. I’m trying to set it to backup my new laptop and have downloaded/installed the software. However, when the WD Backup software gets as far as ‘Select your WD storage device or cloud service’, it keeps giving me the message ‘No backup targets found’.

The Passport is plugged directly into the computer, and I can see the files on it, so the USB cable must be working. I’ve tried restarting the computer and I’ve tried plugging the Passport into each of the different USB ports. Does anyone know what might be wrong?

this is a known issue and far as I know there is not a fix in sight. Please use Win 10 Backup its gonna be your fastest and safest option

Wait, what? You’re saying that having the MyPassport stop working
like this (I don’t think it’s more than a couple of years old) is
a known and unfixable thing? That’s pretty feeble. If I’d known
that, I doubt I’d have bought it in the first place.

Best wishes,


Hi DrSarah,

I have a brand new WD Passport for Mac. I’ve tried 2 machines but can’t see the drive at all, although the drive’s light is on and it’s whirring.

I’m so frustrated with it. I bought it because my MacBook was playing up and I wanted to to the right thing and back everything up, but before I could research into why it isn’t working my MacBook died. I now fear I’ve lost all the info on the machine even though I invested in the device to avoid it. :frowning:

If anyone can help get this thing working I’d be much obliged.

(not so) Smiley Jo


Reply to DrSarah:

Check that the 'User" is the same on both drives.


anything apple was made not work with *, so the odds are stacked against you way before you knew it. Airport for Wifi, Itunes for music, etc etc… airplay to send files, Timemachine for backup…

Did your steps involve clk’ing - Add a Backup Plan ?- I did not see my recent MyPPt assigned" Drv letter in the WD Backup screen UNTIL I clk’d that.