Can't disable sleep on WD Elements

Need to disable sleep for using WD Elements 18TB external drive on a Linux server. WD Drive Utilities on a PC just says “Attach a supported WD drive” even though it shows up in WD Discovery and has a drive letter. ‘hdparm’ under Linux just gives an error if I try to disable sleep.

Any advice appreciated!

Hi @avhjr,

Please be informed that we tested on Windows/ Mac OS only.

Please refer to the article support for WD products in LINUX or UNIX:
https://support-en.wd.com/app/answers/detail/a_id/5242

Please disregard that I mentioned Linux. This issue is present no matter which OS is being used. Assume I’m using this drive under W10. Then it is still the case that I cannot find a way to disable sleep.

Thank you for further input,
Art

WD support is working with me on this and is very helpful. Where we are now is that it’s clear for a USB connected external drive that Windows has various ways of putting it to sleep. Either via the power/sleep settings or via the USB root and device settings. If all these ways Windows can put the drive to sleep are taken care of (and there are a number of posts on the net about this) it’s not clear if the drive itself, internally, can time out and go to sleep on its own accord. If so one way to keep the drive awake is to run an application that periodically accesses it. There are a number of these apps on the net including ‘Nosleep HD’.

It’s also possible that if the drive can put itself to sleep it may be possible to change this internal setting with a ‘utilities’ type program. However the WD tool, “WD Drive Utilities” doesn’t work with the Element. A WD competitor has posts about their utilities and using them to change the timeout.

I have the same issue on Mac. My 12TB Elements sleeps moments after waking. I have the “Put hard disks to sleep” option turned off in System Preferences>Energy Saver, but the Element still slows everything down.