Can't delete TimeMachine Backupbundle

Hi folks! I have a 8TB MyCloud home, I’m running the latest firmware and app, and running the latest version of Catalina (10.15.2).

I used it for a while for time machine backups for my iMac and MacBook. But found after a year for it not to be practical as the drive is basically too slow for terabytes of backup, and restoring and backing up take quite some time.

So I decided to delete the ones on my MyCloud to make space for plex media and specific files to back up. But it won’t let me delete it, as it says “mapped” is in use. I also can’t mount it anymore as it says it not recognizable or currently unavailable. Anyway I can delete this?


Did you turn off Time Machine first?

Thanks for the reply. If you mean turning off in system settings, the iMac is not connected or associated with this backup anymore. Or is there a way/need to turn it off in mycloud?

Oh bizarre.
You should be able to do it with a command line and sudo.

1 Like

Thanks, what should I be typing in terminal exactly? Worth a shot maybe?

Does anyone else have ideas on this?
I used show package content on the drive, in the hope to delete the files of the bundle.
After 4 days and 130.000 files deleted it suddenly said, band was in use.
I don’t get how though.

There two backups on my mycloud home, one from my previous iMac and one of my Macbook.
I only want to delete the iMac backup (although I’m this close to formatting the whole thing).
Everything seems SO SLOW when browsing folders or deleting files.

I just want to use it as essential media backup device, I want to format, but I don’t want to wait a week before my 4tb of media is transferred back onto it. (let alone the hassle of acquiring all files).

Furthermore, im not sure my disc is fully working, it is extremely loud and seems almost always active, spinning, reading, churring sounds of the needle and the disk, it doesn’t sound okay actually.

I contacted WD about both the current matter, as TWICE earlier regarding the issues with the disk.
Aside from the fact that it took a week for a reply, there was never a solution made, they first just point you to the retailer you purchased it at, then the RMA department or the FAQ page of their website.
Or to this community forum, which as nice at it is to have community, it shouldn’t be the customers helping customers.

You can see here:

1 Like

Ah yes, I’m familiar with those commands. I’ve tried a bit of that. I give me the following error.

dikkensimac@Dikkies-iMac TimeMachineBackup % rmdir delete.backupbundle

rmdir: delete.backupbundle: Directory not empty

dikkensimac@Dikkies-iMac TimeMachineBackup %

Try with « sudo » In front of the command line but beware of the command line.

Sudo stands for super user do. It’s like a god mode. You can definitely arm your data if not well handled.

Thanks, yes im familiar with it :slight_smile: Tried that first, but it results in the same error.

Last login: Mon Jan 27 12:08:09 on ttys000

dikkensimac@Dikkies-iMac ~ % cd ~ /Volumes/TimeMachineBackup


dikkensimac@Dikkies-iMac TimeMachineBackup % sudo rmdir delete.backupbundle

rmdir: delete.backupbundle: Directory not empty

Right now im trying this:

Last login: Mon Jan 27 13:25:52 on ttys000

dikkensimac@Dikkies-iMac ~ % cd ~ /Volumes/TimeMachineBackup


dikkensimac@Dikkies-iMac TimeMachineBackup % sudo rm -r delete.backupbundle

It’s processing, but it seems to be just as tedious and slow as in finder, and eventually might run into an “in use” error again. I’ll just let it run and hope for the best.

Hi, I can’t delete files (included TimeMachine file) on shared disk “MYCLOUD-XXXXXX”.
I’m not sure, but I think it’s because I can access it only as guest (

Can you please help me to do it?

EDIT: I tricked the MacOS doing the following:
Command+I on the folder/file (like the TimeMachine backup), then click to check the field “blocked”.
Then close the window.
Now reopen with Command+I and uncheck “blocked”.
Then close the window.
That will help to unlock files and let you delete them.

find any laptop running ubuntu, connect to wifi, find your network drive and easily permanently remove its content :wink:

MacOS is a UNIX-like POSIX compliant operating system (based on BSD Unix). Whatever you can do in Ubuntu you can likely do in MacOS - it ships with all the shells, bash, zsh, etc. and supports most Linux commands. Whatever Linux command is not included can usually be added using either MacPorts or Homebrew package managers (“port” and “brew” commands have near identical syntax to Ubuntu’s “apt-get” command). I have a server running Ubuntu and a laptop running MacOS and I can pretty much do whatever I need to do the same way on either platform. I also have a Windows desktop (for running games), which is the bane of my existence. Anything I can do in seconds on MacOS or Ubuntu takes me minutes or sometimes hours to do on Windows.

you can’t use rmdir to delete a directory that’s not empty. You need to use rm -r. To force it to delete everything you need to add f flag, and to give it root access you need to use sudo. So the full command is:
sudo rm -rf
In your case I believe the directory name is delete.backupbundle so:
sudo rm -rf delete.backupbundle
Note this operation may take a while as there are very many small individual files in that directory.

hi im experiencing this same issue and its saying i dont have permissions to delete the bundle. Unfortunately im not hugely technical so not totally following the suggestions above :(. Would somebody be able to help explain the basics?

Is there 1 line of code that I could enter into terminal for example?

many thanks for your help!