Cant access shares via windows explorer

I normally access my cloud through windows explorer, it appears on the network and then I can click and enter my user name and password and see all my shares.

About 3 days ago all the shares disappeared and I cannot see them, the drive just appeared blank (even public folders)

(I can still see them in WD My cloud app, and no changes in the dashboard)

I noticed that if I create a new share it appears without issue and can be accessed without issue.  Even if i switch the newly created share to private I can access them in windows after I have enter the username and password.

So I experimented with the old (now invisible folders) I toggled one to be public and it reappeared in the network.  When I set it to be private it is now still there and when I try and enter it asks for username and password as expected, problem is when I enter the Username and Password it says access denied (I am 100% sure its correct login as works in the newly created folders).

So basically does anyone have any idea what has happened, as I really dont want to have to make all new shares and copy over.


Welcome to the WD Community.

What firmware are you running on the unit? 

Have you tried resetting the drive? If not, please try a system only restore.

1 Like


Thanks for the reply.

My firmware is v04.01.03-421

Yes I tried a system only restore and once it was back online it had the same issues.  Its quite odd.

I have also tried:

Deleting all the credentials for the cloud out of credential manager in windows

Moving the cloud and pc to a new workgroup

If I use WD discovery and click on browse network shares it only shows the ‘new’ shares

But using WD quick view shows all the shares I just cant map to the old shares as get the same issue with it not accepting my logon

I also have the same problem, and not fixed yet.
Samba all_share file have loss of contents.