Can't access dashboard

@Carlos5302v - I’m using a mac, ‘finder’ is the folder view equivalent to windows.


I have the same error.

Setup NAS.

Created accounts etc.

Verified access to the NAS via browser ( both from home, and from pc elsewhere.

Then one date not long ago I’m not able to access the NAS.

Can log in to wd2go.

Can see the device.

When I select “View Shares” it (eventually) result in the same error message.


The reply is slightly of topic. This topic is about the dashboard (see page 41 in the manual); accessible via http://wdmycloudhttp://wdmycloud.local or  http://wdmycloud:80 redirects to which opens your personal cloud (see page 70)

Sorry that I replay so late

I solve this problem that:

icon" dashboard" on pulpit refer to IP address, sometimes IP address going to change

so please check IP address first: control panel/all control panel items/network map

usually last numbers of IP address has been change

I am no longer able to access my dashboard either. It has been working fine with no issues. I can see my drive and Time Machine is even backing up to it. But, when I clocl on the dasboard shortcut-the Safari browser keeps shoiwng, “Safari can’t connect to server”. 

Any suggestions?



I had exactly the same problem, so I was able to access again to the Dashboard…

1) Go to ‘WDMyCloud’ storage network view from your PC (Window Networks exploring).

  1. Right mouse button from it and select ‘View device webpage’ from the pop up menu.

Hope this helps.

Best Regards,


Network address was messed up on mine. For some reason it changed from to I was able to regain access to dashboard after forwarding port 80 for

I’ve got the same problem yesterday. After firmware update http://wdmycloud goes offline however \wdmycloud was working. Fixed:

  1. I found device’s new IP looking through network.

  2. Then I run cmd.exe and “ping wdmycloud” - the IP was wrong (how \wdmycloud was working?!)

3) After I opened the dashboard using http://xx.xx.xx.xx - it worked well.

4) I tried again http://wdmycloud - and it became alive…

So, the reason for the malfunction is IP changing and OS/Browser caching of it. And I still don’t understand how it was repaired.

P.S. Win7, Dir-300. The access by name (http://wdmycloud) isn’t available from my Android tablet yet…

I’m not a member of the “geek squad” but I had this problem and solved it by unpluging the mycloud, wait 30 seconds, plug it back in, hit the mycloud reset button, and it worked fine. Note: It took about 10 to 15 minutes to recycle.

Solution Found.

During updates, the address of mycloud changed to xxxxx.104 from  xxxxx.108.

Click on Dashboard icon, then properties and change the address to whatever the Mycloud is assigned to.

Hope this helps

I just bought mycloud. when I tried to setup the device through the setup software, it just don’t find the device in my network, but i can see it through explorer. 

AND, I don’t know why, I can only access the dashboard through my samsung galaxy s4… I can’t access through my ipad, mac, windows desktop… 

 If your MyCloud is set up for DHCP access, it’s IP address could change every time it is rebooted. Then the shortcut on your desktop would not find it.

 If your router allows IP address reservation you could reserve the MyClouds IP address in the router so this wouldn’t happen. Another option is to set your MyCloud up with a static IP address. Be very carefull if you do this as you could brick your MyCloud if you make a mistake. Also if you change to static pick an IP address that is not in your routers dynamic (DHCP) IP range.

Finally it works…

After I uninstalled every WD apps, java and reboot, my PC now recognize it and I can access the dashboard.

Thanks, your solusion worked well, for some reason the IP no of the dashboard link was changed… after the ping command in cmd I saw the actual IP number en changed it in the original link and that worked…

Greets Gher


I have MyCloud EX2 installed on my iMAC. When I try to access the sub menus of the Dashboard home screen, the screen dims and no further action happens. Refresshing the home screen doesn’t chane anything.

Appreciate any advise

I cannot solve the issue. The device worked two days only.

1 Like

Ok, I am having same problem. 

wdmycloud/UI is a waste of time (it used to work, not sure what happend? Firmware update?)

Accessing via IP address does get me in, but it’s SLOW AS MOLASSES! No, wait. SLOWER! The WD PC Smartware backup software stopped backing up for some reason a few months ago (as I’ve just discovered) and I am currently trying to figure out why, but being an impatient person, I simply can’t wait 2 to 5 minutes for every page to update / refresh.

Right now I’m on the “check for firmware update” page and it’s been saying “retrieving” for over 5 minutes now. I’m using Windows 8, Chrome. 

Does anyone know of a more reliable NAS device for backing up PC’s as it appears too many people (including myself) are having issues with the WD cloud devices. I’ve even turned off Cloud and DLNA services (this took about 10 minutes) and it’s still not working. Oh, and yes I’ve rebooted it. Many times.

I found a very simple Solution that actually works!



Resetting with Power Off
At the same time as you plug power into the WD My Cloud device, press the Reset button
and hold for about 40 seconds. The device undergoes a system restore and powers on.

Attention: This will delete all your files on the WD My Cloud!!!

So make sure that you have a BackUp or you copy them first, this was still possible in most cases!

Hope that helps!

And yes I had the same problem, and this made it go away!
But make sure to BackUp your files!

  - Soultar17

Soultar17 - No work this workaround

Helpme mycloud 2TB No Access dashboard

For me, the MyCloud Dashboard was not working, but SmartWare worked, and I could see the MyCoud device in my network list and I could exchange files with it.

  1. I used File Explorer to open the Network Screen.

  2. I opened the properties page for the WDMyCloud (right click) icon.

  3. I copied the “Device webpage:” value from the properties list.

  4. I hovered over the WD My Cloud Dashboard icon on my Deskltop

  5. I opened the properties page for the WD My Cloud Dashboard icon (right click)

  6. I pasted the “Device webpage” value into the “URL:” entery in the properties lis

  7. I clicked “Apply” on the WD My Cloud Dashboard Properties screen.

  8. I successfully opened WD My Cloud Dashboard

I hope this detailed list helps someone else.

Steve R.