Cannot Reformat Passport SE

Recently, I accidentally unplugged my 1 TB Passport SE during a file transfer.  It hasn’t been quite the same since. I was able to pull the files I needed from it (although the transfer was very, very slow) and it worked a bit for a few days, however the performance was clearly going downhill (maybe I have a virus?).  The data appears to be gone, so I’d like to just reformat the drive and start over.  There’s no clicking sound and I can feel the disk spinning.  The light blinks a few times when I first plug it in, but then seems to turn off and never come back on.

When I plug it in, Windows (Windows 7) tells me that it cannot access the drive unless I format it.  However, Windows is “unable to complete the format”.  I then tried to format it from the command prompt by typing “format g:” (g: being the drive), but I get the following error:  “The media being formatted has been removed or has become invalid”.

I tried to use the Western Digital Quick Formatter, but it just seems to crash with this output:

Problem signature:
  Problem Event Name:    APPCRASH
  Application Name:    WD Quick Formatter.exe
  Application Version:
  Application Timestamp:    4e84b045
  Fault Module Name:    KERNELBASE.dll
  Fault Module Version:    6.1.7601.17651
  Fault Module Timestamp:    4e211319
  Exception Code:    e06d7363
  Exception Offset:    0000b9bc
  OS Version:    6.1.7601.
  Locale ID:    1033
  Additional Information 1:    acb9
  Additional Information 2:    acb9d3815f4c204a197311dc96813a7d
  Additional Information 3:    e13c
  Additional Information 4:    e13cf6b842e41cf724deb85165061a65

I then used Windows’ Disk Management program and the hard drive appears at 931 GB RAW.  Trying to format it here also does not work.  When I try to delete the data I get “The system cannot find the file specified”.

Next, I tried to just delete everything using Eraser 6.0.9 but I get the following error:  “Attempted to Access a Path That is Not on the Disk”.  I then tried to use Killdisk, but it seems to just sit there with no progress being made.

Finally, I tried to analyze the disk with TestDisk but get the following: “Partition Read Error”.  In fact, I wasn’t able to do much and seemed to mostly just get a bunch of read errors when I tried to analyze it.

The disk appears in Windows Explorer but when I click “properties” it shows up as 0 bytes in size.  When I try to save data to it now I get “g: is not accessible.  The parameter is incorrect.”

I’ve also tried uninstalling and reinstalling the driver but nothing seems to happen.  The disk shows up in Device Manager and I uninstalled it and it seemed to reinstall ok after I restarted the computer. 

At one point I got an error that said something along the lines of “The partition has collapsed” and also something about all NTFS boot sectors being unwritable, however I can’t exactly remember what I tried when I saw those errors. 

Anyone have any ideas on how I can get this thing going again?  I’m not too concerned with saving any data - I really just want to be able to use it.  Any help will be very much appreciated.  I really don’t want to just throw $100+ dollars in the garbage, especially since I just bought the thing like a week ago…

try to write zeros with Data Lifeguard

Thanks for the help - but no luck.

I managed to write zeros to it with another program, but it seems that Windows is having a problem communicating with the drive.  I’ll test it out on another computer when I get a chance…

Thanks again.

looks like you have a bad one and need to replace