Cannot download WD Security for Windows

Hi,

I’ve tried to download the WD Security for Windows several times but an opera file gets downloaded instead. I use My Passport Ultra 1TB. I tried reaching someone on twitter but no response for over 8 hours. Cool that I found this forum and I need assistance asap.

Thank you.

@fynewily Have you looked at this, https://www.wdc.com/products/wd-recertified/my-passport-ultra.html

Where are you trying to download this from?

I’ve been trying to download it from this link: https://support.wdc.com/product.aspx?ID=240#WD_downloads.

Sorry, but your link only takes me to the ultra page. The download link at the footer still takes me back to the above link. How can I get over this please?

Not sure what’s happening for you.

When I click the link you provide, then click the link for the WD Security software, it then gives “Download” button which, which clicked, successfully downloads WDSecuritySetup_for_web_2.0.0.48.zip

Here’s the direct link at that button:

http://downloads.wdc.com/wdapp/WDSecuritySetup_for_web_2.0.0.48.zip

I can’t install it because my work PC prevents that, but is that not the correct file?

If not, contact a forum admin – they may be able to help get the web folks to correct the link.

Thank you. It must be an issue with my PC. I used another PC and was able to download it.