Cannot detect 1tb WD Blue

Hey there, I’ve just installed a new 1tb WD Blue internal hard drive into my tower computer using a SATA cable, but my computer can’t seem to detect the drive at all. I have tried installing “Acronis True Image WD Edition” but it can’t do it either. I have also tried right clicking on the computer icon, then ‘Manage’, but nothing I do seems to get the drive to show up. I have had previous experience of a 4TB drive not being detected, but I remember finding some software somewhere that fixed it.

I have recently installed a new graphics card and am wondering if the power consumption might be too much to support the drive as well. Would that do it?

Specs:
Windows 7, 64 bit
Intel i7 processor, ASUS motherboard.

Hi,

You will need to verify if the hard drive is being recognized through the BIOS, and also attempt another SATA port and/or SATA cable.

Hi,

Don’t know if you already have an answer. You should check if the disk is visible in BIOS. If it is try te steps below.

PROBLEM:

Disk not visible in MyComputer, Disk Management or Device management but visible in BIOS

SOLUTION:

Open Device Management --> View --> Show hidden devices
Click the HDD/SSD that isn’t visible in disk management --> uninstall device
Reboot

For disks that were already in use in Windows: They will now be visible again in MyComputer

For new unused disks:
Open Device Management
Select Disk Management
Select the correct disk and initialize it (MBR format if less than 2TB or older windows version, GDP if more than 2TB)