Cannot access/open drive in windows 10 file manager

1 -New WD user Win10. Have had a NAS before but not WD.
2 -WDMyClound shows on right window of file manager. If I click what I think is the Dashboard opens.
3 - If I click on “network” on left window, it does not open up except once when I was able to copy a few thousand songs. That time when I clicked “network” it opened.
4 - WD Access does not open after installation.
Been messing with this of and on for three days , no luck.

@duxdad I am having trouble understanding what your problem is, but, look at this topic and see if it helps.

Thanks, that fixed the problem although not comfortable with the security issue.
Now on to #2, today I tried to test access from my local Starbucks unsuccessfully. Not sure if I need port forwarding, didn’t think so if using WD app.

Thanks again.

Follow up, lost access to the drive via file manager after having it work.
Called WD support today and worked with a very pleasant gal. It turns out that none of the three PC computers could access the WD My Cloud through the “Windows File Manager” despite one of them working just yesterday. Also WD Access also does not work/function or even load. We did the “Windows Features On and Off” several times.
Finally the best solution was to select “Network” section in the search bar, add the IP address of the “My Cloud” ex. // and pin the results into “Quick Access”.
I think a Windows upgrade may have killed the other solution.
Think WD needs to update their various programs supporting Windows 10. Getting this up and running was a real pain.

This sounds similar to my problem. I’ve always accessed MyCloud on my home network via Windows File Explorer. I don’t know if Windows’s latest update is responsible, or not, but one day when I clicked on Network on the left of the File Explorer window, it stopped showing MyCloud on the network.

Today, I updated my MyCloud firmware. MyCloud is now showing in File Explorer, but when I click on it, it doesn’t expand MyCloud’s file system as before. It shows icons for MyCloud’s two personalities, instead. When I click on either of those, it doesn’t expand the file system, either, it merely opens a browser tab for the respective web interface, either the UI for MyCloud as a storage device or to the Twonky Server for MyCloud as a media streaming device. This is no help for manually copying files from my laptop to MyCloud, which is what I really want to do and which I could do easily before.

Does this sound related to your problem, or is it a different problem for which there’s an easy-to-no solution?

Can you map the My Cloud to a drive letter? Can you ssh into the My Cloud? If so try
showing us what “ls /etc/samba” shows.

Yes, sounds like the issue I had.
What I did was:
1 - copy the ip address of the “My cloud”
2 - Set the file manager search box to “networK” ( not sure if necessary but it’s what I did)
3 - Paste the IP address of the “My Cloud” into the search box of windows file manager. and hit return.
You should then see the various partitions(?) on the right. Just drag and drop to the “quick access” area.
Let me know how it works out for you.

When I get to step 2 and set the search area to “network” on the left of the file window, the two “personality” icons for MyCloud are apparent as in my earlier description, but when I search on the IP address of the device (step 3), the icons disappear and the search returns, “No items match your search,” despite the IP address being the same everywhere it appears, i.e., property sheets of both icons, both browser tabs for device personalities, and search box parameter. When I clear the search box, the icons reappear.

When I get “network” in the search window I backspace to remove it then enter // return.
The “personalities” for lack of the correct term show on the right window then I drag and drop them to “quick access”

“Can you map the My Cloud to a drive letter?” Apparently not. There have been many Windows Explorer interface changes.

  1. “Map network drive” works differently now and uses a higher-level UI which recognizes no devices on my network. It wants to map a drive letter to a “folder” instead of to an external device itself. I would want to map the whole drive. Since I can’t see MyCloud’s contents, I can’t see its folders (i.e., parts of the file system) to map any.

  2. “Access media server” addresses the wrong personality; I want to access the raw device.

  3. “Add a network location” is for enrolling in *commercial *cloud services. It fails when I specify the URL for MyCloud instead of one for some service over the Internet.

  4. “Add devices and printers” doesn’t list “disk” or “storage” as an addable device and MyCloud is already listed as an “other” device under “Bluetooth and other devices.” The only option presented there is to remove the device from the network,

“Can you ssh into the My Cloud?” No.

  1. Secure Shell (ssh) is not a recognized Windows DOS command. It’s a UNIX/Linux command. I don’t have a UNIX or Linux system from which to issue it.

  2. Windows’s “Connect with remote desktop connection” is for letting remote desktops connect to this PC, not to let this PC connect to DASD on the network. I have it grayed out because I don’t have a remote desktop from which to work.

“…try showing us what ‘ls /etc/samba’ shows.” I recognize “ls” as a UNIX command and /etc as a UNIX directory. I have no visibility to MyCloud’s internal file structure, so I don’t know if it has a UNIX-like file system or not. My Windows system has neither an “ls” command nor a /etc directory. I have no idea what samba is.

First of all samba is the software that allows folders on the My Cloud to be mapped to
drives on the windows PC. I don’t understand why you want to map the entire drive? What do you mean by raw device? The Public folder is the normal folder to map. The partitions on the My Cloud are formatted as ext3/4 filesystems. These filesystem are not recognized by windows.
To ssh into the My Cloud you need to download putty. I asked these question because on my system at times I lose the ability to map folders. When this happen I look at /etc/samba and see that most of the necessary files are missing.
I have mapped my My Cloud Public folder to my windows 10 pc using
in the map network drive. Use the dip address when the My Cloud does not show up under the browse button.

Oh, that window. I was using the search window off to the right on the same level.

When I do it the way you suggest now, it just opens another new browser tab for the device.

When I drag either icon to Quick Access (a section I have never used before), nothing seems to happen.

BTW, if I click on “This PC” on the left and expand its contents to the next level, MyCloud is not listed, but in the main window, it does appear as a media server under “Network locations” (for this PC), and the locator indicator at the top of the window reads, ThisPC\WDMyCloud. Clicking on MyCloud in the main window does expand down the tree structure to the next level, but only for that Share on MyCloud allocated to this PC. It’s clicking on “Network” on the left that doesn’t work the way it used to, i.e., give visibility and access to the whole device.

Re. “I don’t understand why you want to map the entire drive?” One reason, as admin, I want to move data from one partition (Share) to another before eliminating users, reorganizing the drive, and reducing the number of shares.

“What do you mean by raw device?” I probably used the wrong term. I didn’t mean that I want to program it like a WD engineer. I simply meant that, as admin, I want access to all shares at once to perform actions as in the previous paragraph, as opposed to

  1. access to one share at a time as an ordinary user, i.e., as an ordinary user accessing only the share(s) assigned to me, and
  2. not have the Media Server software in the way to keep me from accessing non-media files (e.g., documents) that may be out there.

“The Public folder is the normal folder to map.” I don’t use the Public folder. MyCloud is for my use only and all data are private. When I set up my MyCloud, before I knew how it really worked. I assigned Users to each of my devices, laptop, tablet, phone, etc., each with its own share. Now that I’ve used MyCloud for awhile, I realized that all data are mine and I should manage them as a single folder-based file system of my own design like any other external disk drive regardless of from which of my devices the data originated. It’s less confusing that way. That’s why I want to reorganize as in the first paragraph above. If I want to give another person access to and personal space on MyDrive, I can always add another user (person) and give them a share later, given the space. If I want to share some of my data with another person, I don’t give them access to MyCloud, I move it to OneDrive (Microsoft’s cloud) and send them a pointer.

“The partitions on the My Cloud are formatted as ext3/4 filesystems. These filesystem are not recognized by windows.” So I figured.

“To ssh into the My Cloud you need to download putty.” I’ll check it out.

Download PuTTY - a free SSH and telnet client for Windows

“I have mapped my My Cloud Public folder to my windows 10 pc using \\Public in the map network drive.” Thanks for clueing me in on how you’re using your Public folder for the mapping. I may have to try it just to see how it works.

I have the same problem with my WD MyCloud, WD MyBookLiveDuo, and a Seagate GoFlex Home. In Win 10 the several windows folder types appear (Music, Album, Pictures, etc.) but the partitions themselves do not. I tried the search for the IP address and received no results. Could the Netgeat D2200 (POS) router be the culprit?

It appears you may be accessing the My Cloud DLNA server, not the My Cloud SMB file server. Make sure SMB 1.0 is enabled in Windows. Microsoft disables that option in recent updates. See the following WD Knowledgebase article:

Nope. Not that, mate. All three options for SMB are turned on and have been. Followed other directions from Microsoft about starting certain services and they are already turned on.

Next answer.

Make sure Windows 10 Network Location is set to Private. If set to Public it will typically block access to most local network devices.

It was a simple setting in Windows. Opened Network Settings and went to Network Connections>Wireless Network Connection> Internet Protocol Version 4 > Properties > Advanced > Enable NetBIOS over TCP/IP. The default setting of Use DHCP is why none of my NAS drives were showing. Thank you Western Digital for calling me and walking me thru the steps.

Just updated windows 10 and looked for my shared file server, but the only thing I found on “Network” except for printers etc was “[LS-WTGL459] TwonkyMedia : PVConnect: Windows Media Connect”. It only started as a media server.

I knew I had a shared folder on the LS-WTGL459 server.

I right clicked on Network and added/mounted a new drive as \LS-WTGL459\share and now it works again.