After windows 10 last update (version 2004) -no access my cloud through file manager

After the last update windows 10 (ver 2004) I cant access my cloud through file manager.
I check all the tricks …but nothing helped…
the only way to upload files is through internet but for a 5gb file this is a very slow procedure…

is there any solution?

Make sure SMB1.0/CIFS is enabled in Windows 10. Microsoft may have disabled that option in Windows 10.

How to Enable SMB 1.0/CIFS File Sharing Support on Windows 10

Also check to ensure the Windows Network Type is set to Private not Public.

all the tricks I knew! …are checked again…but nothing!!

just before the update all was just fine!!

Couple of troubleshooting steps. Set a static IP address, or reserve an IP address for the My Cloud within the network router. Reboot all local network devices. Check any security software installed to the computer, some may block access to local network devices.

This assumes the My Cloud fron’t LED is blue.

I will give a try with your solution…

from my laptop (windows version 1909) everything working just fine…

the problem is definitely in windows new version!!

by the way I cant understand why WD stopped the windows app???

that could be an alternative method!

I followed all your steps but still I don’t see my Cloud files on network
what to do???

Ho anche io lo stesso provlema, l’ho anche segnallato in un post di qualche giorno fa ma nessuno mi ha preso in considerazione, il 2 giugno 2020 ho anche aperto una RMA ma l’assistenza tecncica non mi ha ancora risposto. Concludo precisando cho sono tornato a Windows versione 1909 e \ \wdmycloud funziona perfettamente.

I have the problem, I also reported it in a post a few days ago but nobody took me into consideration, on June 2, 2020 I also opened an RMA but the technical assistance has not yet replied. I conclude by specifying that I went back to Windows version 1909 and \ wdmycloud works perfectly.


If the “friendly name” isn’t working - try accessing using the ip address address.

Also - can you still get the dashboard?

Can you ping the NSA from the pc?


If the “friendly name” isn’t working - try accessing using the ip address address.


Also - can you still get the dashboard


Can you ping the NSA from the pc?


I downgrade to version 1909 and everything is back to normal…

Bring back the Windows app…!!!

and update it everytime if is needed …



I downgrade to version 1909 and everything is back to normal…

WITH THE 2005 version IT DOES NOT WORK !!!


We have to stuck on 1909 version?

Its WD responsibility to find a solution!!!

I think that the old app is a solution !!!

We have to stuck on 1909 version?


Its WD responsibility to find a solution !!!

Hopefully in WD !!!

I think that the old app is a solution !!!


I’m a bit confused. Microsoft pushes out another update that breaks access to the My Cloud, and somehow it’s WD’s fault and up to WD to find a solution to something Microsoft created?

Much like the past when MIcrosoft disabled SMB1.0/CIFS on users with an update (or when Windows 10 was installed) which then broke access to many NAS devices (unless one used the NAS’s IP address), WD (and possibly other venders) will have to figure out what setting change Microsoft has made and figure out a way to undue it so their product(s) work again.

The blame is on Microsoft for once again making changes that break access to NAS devices (WD in this case, haven’t heard if other manufacturers are affected). And once again it’s up to the venders to figure out the Microsoft change and create a workaround…

You are right !!! We are always the losers, I hope they find a solution not to throw away the WD MY CLOUD.

I said that ,because with the desktop app (which WD determine) ,the access could be undisturbed.

The My Cloud Desktop app has been End of Life since 2016 and has been non functional for at least a year now with several recent My Cloud firmware updates. Yes its not good that WD stopped supporting that program but it has been that way for some time now.

I’ve had problems with Windows 10 since updating recently to Build 18363 where I cannot drag and drop files to several NAS boxes (WD and Synology). I can copy the file using copy/paste but not drag and drop. Stupid, but somewhere in that update Microsoft changed something that broke dragging and dropping files from my PC to my NAS devices.

1 Like

Well. . . I also view MS updates as a curse.

I had one O/S corrupted by an unexpected, unwanted, undeferrable update that forced a software reload.
The next update broke network access to the NAS boxes until I disabled IPv6. . . which I wasn’t using anyway (???)

But to the point. . . . .if you typing the IP address in the file explorer. . . .slashes in one direction yields the dashboard. Slashes the other way yields the files. Note: Use file explorer; not Edge or Internet Explorer.

Speriamo in qualche buona novità da WD.