Can not use more than ~500 GB

Hello, I can’t use more than 500 GB from free space after that I get “no space left on device” is the second attempt to transfer 1 TB of information. I reset the machine, formated the hard disks and tried again, same result no space after ~ 500 GB. My Cloud Mirror firmware is 1.04.05 and it shows 1.42 TB free, I use two users with no qouta, and two methods of copying, classical mapping on pc and rsync. Write to support a week ago and no response 

Support Case Detail [deleted]

df -h.png

Hi cipisoft, welcome to the Community. Please note that this is not the typical or intended experience with the product and provided support. Have you tried doing a system only factory restore or have you verified if the same problems happens from another PC or device?

This is bizarre. I must say this user (cipisoft) provided incontrovertible proof. Not sure why WD tech support did not respond to his request for help.

What does the output of 

df -i

give you?

I’m wondering if you have so many files on there that you’ve run out of inodes"

Yes indeed it was a limitation to 1.9 millions inodes I remedied the situation and now is ok. I have 3.8 milions of files and folders on the 900 GB and increases.

Wow.  The Mirror has a limit of 1.9m inodes?

The EX4 (similar software) has a limit of 275million.

mine yes, right now I have 121 million and is ok, I stopped wdmcserverd from crontab hope to be ok until the end, I  haven’t finish transferring all my files  72%.

how to solve this problem:

- backup your data (On external drive !)

  • umount -l /dev/md0 (in my case, yours can be md1 … 2 …3 )

mke2fs -n /dev/md0 (in my case, yours can be md1 … 2 …3 ) copy inodes numbers

-  mke2fs -N number-of-inodes -t ext4 /dev/md0 (in my case, yours can be md1 … 2 …3 )

- mount -t ext4 /dev/md0  /mnt/HD/HD_a2

- restore

hope I haven’t forgotten anything :slight_smile:

after a week from WD support:

Then please follow these instructions:

If the device is set to use RAID0, backup your data first.
Take out one drive, connect it directly to some Windows computer using SATA cable or USB enclosure and wipe it using Write Zeros functionality of our DLG utility:
Then put it back to the NAS and have it rebuild the RAID.
When rebuilt, do the same with the other drive.

Will not solve the problem !


Please update to the latest firmware that was released yesterday and let me know if it helped.

Will not solve the problem !

although I have not tried these solutions and who knows maybe it is a chance to work :))) or not