Can My Cloud actually stream music? Can somebody help me please?

Hi all,

I really hope somebody can help me. I own two 3tb MyBookLive and these are a dream. My 4tb My Cloud is another matter.
I had all my films and videos on the My Cloud with a wired network to my WDTV box and this was fine. I also streamed my music wirelessly via the in built two my server from both of my MyBook Live and again, this was fine.
I recently decided to have a change and I put ALL my music on MyCloud and split my films and videos between the two My Book Live devices… So far so good.
That is until I try to listen to music which is now going wirelessly from My Cloud, in short it doesn’t work.
It seems to be always scanning which means most of the time my music isn’t available. I can play my music wirelessly but very sporadically, and it can take 10 minutes for my library to even load!!
I have an album on right now, it took an age to load, and now it skips songs, pauses songs for 5 minutes at a time, and is pretty rubbish compared to the steaming from My Book Live which was pretty perfect.
After I transferred my music I re built my database, which took a week, also scanned, but know know what else to try.

Is anybody able to help??

Btw, I have the new firmware released in May.

I stream media from MyCloud without trouble.

This might help:

I might suggest looking at your wireless network; checking signal strength, looking for channel clashes, etc.

A week to re-scan the DLNA database? Something is wrong. Twonky scans my 2.1TB of media in about 15 minutes.

How is your My Cloud connected to your router? What type of router do you have? How far away is it from your WDTV box or whatever you are trying to stream to? How is your Twonky set up? See example images below.

Click on, tap or activate images to enlarge them.

I stream my music too without any problems, mostly to my cell phone.

Hi cpt, thank you for your reply.

The server on the dodgy My Cloud is DLNA, i am a bit of a novice I’m afraid as I don’t know the difference between twonky and DLNA, although I do know that when I had my music on the MyBookLive twonky server I had no problems.

I have just checked and my wi fi strength in my music player is saying 100%.

I’ve read elsewhere that you can change from dlna to twonky on My Cloud, should I try that do you think?

Hi cat0w

My Cloud is plugged directly into my router, I have 200mb broadband and the router is pretty decent.

I am only streaming it across the room… I have been streaming music like this without problems for years, until I decided to stream my music from My Cloud instead of My Book Live.

Twonky IS the DLNA media server within the My Cloud.

Don’t know if you mentioned or if its been asked but what DLNA client (ie the device your trying to stream to) are you using?

Have you enabled Media Serving in the My Cloud Dashboard on each Share that is holding your media within the My Cloud?

Hi Bennor,

Thank you for your help, I’m trying to stream to a NP30 Media player. I have enabled media sharing as well.

It takes an age to get into the UI as well, but this is the error I came home to if that helps. I really am not a networking ■■■■■, but I’ve been streaming music for years without issue.

So now the dlna says it’s streaming, but twonky isn’t… Does this help?

@pgreen I hope you checked out the two images I added to my first post. You may want to look at Twonky and see how it is set up for your NP30 Media Player.

Apologies cat0w I checked, and had exactly the same settings as you, different media receivers of course :wink:

Can you suggested any other settings I may have missed/inadvertently messed up?

The first screen capture (the Dashboard) does not indicate its streaming, rather its just giving you the option to turn on or off “media streaming”. The second screen capture (the Twonky admin screen) will only indicate a streaming status when a device is actually streaming from the My Cloud. The second screen capture indicates nothing is being streamed.

Have you configured the My Cloud for a static IP Address? Preferably assigned the My Cloud a static IP within the network router or gateway.

Edit to add: When in doubt one might want to do a 4 second reset or a 40 second system restore. Sometimes a reset or restore can fix certain issues.

Hi Bennor,

I tied a 4 second reset but it didn’t do anything, meaning the machine didn’t actually restart…

I have now changed the settings to a static ip… Twonky still says not streaming though :confused:

That image shows that Twonky is currently scanning for media. It will say ‘not streaming’ until you stream some media from it. Have you just turned on the DLNA media server? If you hit ‘Detailed Status’ it will show you what directory it is scanning, updated every 30 seconds. If it’s not changing, something is wrong; possibly a bad file.

Did you read the FAQ? Judging by your confusion about Twonky and DLNA, I suspect not… Do read it; it may improve your understanding.

I see no comments yet about the OP’s media streamer that is made by Cambridge Audio. There have been plenty of posts here about the Cambridge streamers, and a lot of people have has trouble with them and streaming from NAS devices. So, suggest the OP search this forum for keyword: Cambridge audio and read the various posts. I helped a guy once with issues he was having with a Cambridge device.

I can stream music from My Cloud either as DLNA or a network shared source to many devices and ALL work. Devices include: computers, WDTV, iPhone, iPad, Kindle tablets, Chromecast, Fire TV and lots of different mobile apps that either stream music (etc) as DLNA or shared sources. I have NEVER needed to futz with the My Cloud Twonky settings. If everything else is set properly Twonky works great.

I think the issues OP is having may come from Cambridge Audio device; check its settings, etc…

Thanks everybody for their help.

I changed to a static network, and rebooted. So far so good, twonky is scanning through my files much much faster than before, and I managed to play a whole song while it was scanning, which I couldn’t do previously, so hopefully this has done the trick, fingers crossed.

Thanks again.