Camera roll backup not completing

Hi folks,

My automatic camera roll backup refuses to complete.

Brand new My Cloud Home 6TB, iPhone 6 running iOS 12 and the latest version of the WD app.

When I initiated the first backup of the approximately 4000 photos on my phone, the app leapt into action and started backing up immediately. However, after about 500 photos it stopped and has since worked only sporadically.

Over a few days while I tinkered with the app, several batches of about 500 photos were uploaded, but it has been stuck on the final 1000 photos for over a week without any progress.

I have tried:

  • deleting the backup & starting again (same issue occurred)
  • variously restarting the app, turning on/off Auto Backup and Background Uploading, and clearing the app cache
  • restarting my phone
  • restarting the My Cloud Home
  • unplugging and re-plugging the Ethernet cable
  • leaving the app in the foreground and disabling auto-lock on my phone
  • ensuring I share location information ‘Always’ in phone settings

I have also tried taking new photos in the hope of re-triggering the backup process, however it backs up the new photo but doesn’t resume on the older 1000.

The only thing I haven’t tried is deleting the app, as my understanding is that this deletes the camera roll backup and I’m hesitant to go through this again unless absolutely necessary.

Meanwhile, I can use the app to browse the backed-up photos, they load quickly and it is relatively responsive.

I have trawled through the support articles and cannot find any information about how to manually trigger the backup process - everything states it is automatic.

I am at a loss as to what the problem is! Appreciate any suggestions.


  • Ensure the phone is WiFi connected
  • Disable Auto Backup
  • Clear the app cache
  • Close the App
  • Reboot the phone
  • Open the App
  • Enable ALL the Auto Backup options including Carrier Network

If this fails, it’s possible the backup job is stuck on a particular file which means locating which file, manually move to the My Cloud and delete the file from the phone. Just a suggestion…have no idea if this will work or not.

Hi socallinux and mike27oct,

Thanks for your suggestions. I tried both of them, several times, with limited success. On first attempt with each they seemed to trigger a slight advancement in the backup process - a few hundred photos. However, it once again stalled and I was unable to reproduce the same result on subsequent attempts.

For my most recent attempt, I left my phone on the charger with auto-lock set to Never and the app in the foreground for about 4 hours. Not a single photo was backed up during that period.

While I write this post, it has uploaded a couple of newly-taken photos but is stubbornly refusing to complete the backup of several hundred older photos. It seems to have a mind of its own and will only work on its own terms!

I have read a number of support articles which haven’t been particularly useful - for instance they don’t mention auto-lock and simply reiterate that the process is automatic.

On a side note, I have a MacBook automatically backing up to the drive with Time Machine and it has worked quickly & flawlessly, so I feel I can rule out network speed issues.

Mike27oct, thanks for the link. I see there are other discussions linked there so I will delve further into the forums to see if I can find a solution.

The best way for this to work is to delete the entire folder of uploaded files .Start over, and a new folder will be created and all files will be uploaded if there is no interruption of uploading.

I realise this was a while ago, but wanted to note that after many hours of tinkering and clean-slate backups, I eventually got this working.

Not because of anything I tried, rather a new version of the mobile app was released. I started from scratch with the new app and it worked first time.

Despite tearing my hair out in frustration at the previous version of the app, which was - in hindsight - incredibly buggy and causing all my problems, I am very pleased with the current version. It is a vast improvement on the old one - in particular the background uploading works really well.

Thanks to those above for their helpful suggestions.