Blu-Ray Playback


I have recently purchased a WD TV Live with a view to ripping all of my DVD collection as ISO’s and playing them back via a network share from my NAS box, complete with menu’s et. al.  This works perfectly! :slight_smile:

Over the weekend I decided to buy an internal Blu-Ray drive for my PC and test ripping some Blu-ray discs as ISO’s.  My understanding was that menu’s are not supported, but that the largest video file in the ISO would automatically be played back by the WD TV.  Unfortunately, this does not seem to work at all; All I get is the spinning orange graphic.

I have tried via wired and wireless network connections but get the same results.  I’m using DVDFab to create my DVD & Blu-Ray ISO’s so decided to try creating an .mkv file, but this does not play either.  I have also tried copying the .mkv files onto an external HDD and plugging it directly into the WD TV but this yeilds exactly the same results.

I’m using the latest firmware, but can see that there have been some problems since its release.  Could this be my issue or am I missing something?

Any help would be appreciated.



I think your post is in the wrong forum. This forum is for the 2009 model WDTV Live HD and 2010 model WDTV Live Plus.

The forum for the 2011 WDTV Live Streaming Media Player is here:

The forum for the 2014 WD TV Media Player is here:


The moderator has now moved my post here, so I beleive that this is now the correct forum.  My question relates to a 3rd Gen WD TV Live Streaming Media Player.

As above any info would be appreciated.



well the wired / wireless bit is a red hering

that would only effect the connection link rate and stability

I would recommend to take a closer look at how the .iso .mkv is being created or shared

you don’t tell us if you’re using a media server, most media servers don’t support iso’s and some still don’t support .mkv

besides that dvdfab I’ve used for ripping by never for creating .iso file so no clue what it’s doing

but the WD definetely plans iso and mkv just fine, if they are encoded properly

I have hundreds of MKV rips of DVDs and Blu-Rays, mostly ripped with MakeMKV.  They all play fine for me, and have with any firmware version from the last several years.  I access them via SMB (“Windows”) shares from a Linux/Samba server.  Never had any issues playing any of these files since I wired both WD SMP units.  Trying to use Wifi with high bitrate Blu-Ray files (40+ Mbps) can be problematic.

Hi Guys,

Thanks for the feedback.

I know the difference between wired and wirless connections only effects bandwidth (over 20 years working in IT), but wanted to give as much info as possible about my setup and what I had tried up to that point.

Anyway, it turns out that restoring my WD TV back to the factory defaults has cured the problem and Blu-Ray ISO’s / MKV’s work fine now.  No idea why…

Once again thanks for the input.




As a further update it would seem that my problem is only partially cured…

If I put the player into standby for anything more than a few minutes the problem returns; no playback for MKV or Blu-Ray ISO, although DVD ISO’s work fine.  I don’t think that this is a networking issue as I have tested MKV’s from an external HDD and they still do NOT work.

If I reset / reboot the WD Player the problem goes away until I put the machine into standby again and wait a few minutes at which point the problem comes back!

Could someone from WD please look into this?  As stated in my original post I’m using the latest firmware.



Have to admit that I don’t ever bother putting my units into standby.  The power savings is virtually nothing from what I recall measuring, so I did not see any point.  Thus, cannot say if this is an issue for me or not.  Will try to remember to check it out.