Bios does not recognize WD20EARS


I came here for help since I’d hate to RMA this HDD since I just got it and seems like I’ve been having a lot of broken stuff lately (memory, PSU etc.).

So the problem:

I got this HDD today, I installed it and I started running HD Tune errorscan. Then I accidentally told Firefox to download a file to the HDD and both Firefox and the HD Tune froze. I tried shutting them down from task manager, it didn’t work so I restarted the computer. Then all of sudden the POST seemed to take forever and when it got to BIOS it didn’t recognize the HDD. I tried booting into Windows and all I got was an endless loop of the Windows logo. I would really much appreciate any help I could get, thanks.

The setup:

i5 2500K

Asus P8P67 Pro

8GB Teamgroup 1333MHz CL9

Windows 7 64bit

I used the motherboards own sata ports. I will try the other sata ports now (marvel or something…)


I’ll suggest you to test your drive with a different data cable if possible test your drive using a different computer.