Before you pack up your WD and return it, let's talk about Copying Speeds!


#61

hello again,

surely the file is in /usr/sbin…

I have tried issuing the command as another user (no root) and then I get the same output as you get: sh: update-rc.d: command not found.

So, as far as I know you HAVE to get access as root.

I had a login problem today as well (access denied for root) and I did a system restore from the web access (Settings, Utilities, System Factory Restore, System only. This will only remove the users you have created, NOT the data you have put on it in the shares. After this I could use root/welc0me. Maybe this will help you to


#62

Acces denied, with root / welc0me, since 3 days. I think this is not the good password. If you could help me to log as root and find the right password. Thanks a lot !


#63

ptiscarabee: have you tried system restore yet?


#64

I have made the system restore again, I had already done it yesterday. Same situation, I can login in with sshd, but no with root…


#65

In that case, I cannot help further, sorry


#66

maybe they have changed the password in the last systems ? Do your system propose the also the sshd login when you activate the SSH ?


#67

I do not know what sshd is…


#68

when you activate the SSH functionality, you get a message that explain you that you have to login with the id “sshd” and you must then choose a password. If you don’t know this procedure, that means it is somethnig knew, as I thought.


#69

you mentioned EX2 in an earlier post. Is that what you actually have?

this forum is for the basic mycloud device only and I am not sure of any detailes on the other versions.

If you have the basic mycloud and not the mirror, EX__- etc then somthing is wrong with your configuration and you need to do a system only restore

If you have one of the other devices please post in the proper forum and you should find people with knowlage of it


#70

hi guys is this not all ready disabled in the latest firware  update

/etc/init.d/wdmcserverd stop

/etc/init.d/wdphotodbmergerd stop

update-rc.d wdphotodbmergerd disable

update-rc.d wdmcserverd disable


#71

no. just is now well behaved so no real reason to disable it anymore


#72

The sys-v package, which contains the update-rc.d command, is not any more installed on the latest versions of MyCloud. It’s Western Digital that will oblige people to accept their policy… Very dommage, I will get my Cloud back, it’s not acceptable. It’s a pity.


#73

First, I have to say thank you for taking the time to post such an extensive post.  I was a little flustered by the speed of my WD MyCloud EX2 until I read your article. Now I have hope.  I set it up about 24 hours ago and began moving extensive amounts of data to it (about 1 tb).  On my windows desktop, it seemed ‘okay’ but a little slow.  But on my Mac, browsing the data seems painfully slow.  I’m going to try your fixes, then let it run for 24 hours to see if it runs better.  I’ll post my results after I try this.


#74

Hi, I have purchased My Cloud 4tb a week ago and after setting up the equipment and uploading content from my computer to the cloud storage it suddenly stopped working. Now it only shows a white solid led instead of the solid blue. I have tried all solutions such as changing Ethernet cables, unplugging, resetting the equipment and nothing seems to work. I have now requested a replacement with amazon. However, how can I delete the information contained in the wd my cloud storage if I can’t access the equipment?  Many thanks,


#75

Hi,

let’s talk a little about a “before buy” rather than a “before I pack and return”, please.

I would like to buy WD My Cloud Mirror device to be used as a RAID 1 backup solution for my photo (I’m a photographer and I need a mirrored backup for all my RAWs+worked JPEGs).

I would like a synthetic description of the status of the indexing issue, as I think it will kill the device once I tranfer on it my thousands of GB of photos. As we are speaking of a device that costs some hundred dollars, it would really make me furious to discover that is doesn’t work for such a simple usage and stupid problem (while my hard earned money have really gone).

As far as I have understood the performance and lock-up problems are all due to the indexing service that wildly runs on the device for each and all directories. It was possible to manually fix the problem using SSH and disabling the useless services but for some reasons WD staff decided that that was not to be done and removed the command/doesn’t allow to connect as a root to the device anymore?

And it hans’t come up with a solution of its own to the problem up to now?

Let’s ignore the idea about voiding your warranty by removing or installing services on a NAS…

Is this all right or I have missed something?

With these premises, should I really buy one of their NAS?

Thanks in advance


#76

I have 4 non-WD NAS devices besides the 2TB WDMyCloud, and  not saying that they are anything special, BUT this thing is the ABSOLUTE worse piece of junk ever perpetrated on a human being.  It drops off of the network, it’s slow as cold molasses (I have it wired on a 1gb switch) with any PC wireless OR wired.

It’s just plain unstable.  I’ve had to restart it by unplugging power, pressing reset, plugging in the power and holding reset for up to a minute, just to bring it back to life at least a dozen times.

I have a USB MyBook connected to this thing and in combination with the MyCloud I can’t imagine a worse combination.  Plugging the MyBook into the MyCloud brings down the MyCloud and of course, the MyBook with it.

The Utilities / Web Interface look like they were put together in a shoe repair shop.  Talk about confusing userids and passwords and CAPtCHAs.  Even logging into this forum requires a CAPTCHA … shheeess

I’d relabel this thread, :“before you even THINK of buying a WD MyCloud, let’s talk”


#77

ditto, I bought 2 of these 2TB MyClouds and a MyDrive and regret the day I did it.  They worked fine until the 2nd FW ugrade and since then, for the last year or so, it’s been a disaster.  These things are an abortion that failed.


#78

Raphael,

Thanks for the excellent and thoughtful post.  It lead me to discover that although I had a GB network connection to my iMac my iCloud was connected to my 100MB DSL modem and wasn’t getting all the speed possible.  A simple reonnect upped my transfer speed greatly. 

I had seen another post about disableing the indexing programs to stop the disk thrashing and ultimately extend the life of the backup.  Having done that my 6TB mycloud does actually stop thrashing after a while.

I had observed that small (10s or 100s of MB) transfers were quick but multi GB transfers oredicted that they would run for several weeks.  Your discussion of the effect of limited cache on small file transfers helps me understand what is going on.

I am also storing hundreds of thousands of photos on mycloud strictly as a backup store.  I am curious how you use your two WD drives to provide backup.  Do you connect one drive to your MAC/PC with USB 3.0 to back up files, then move the USB 3.0 conection to the mycloud dirve to transfer over the files? And what about the DNLA service on mycloud.  You mention that you don’t use it.  Other posts have suggested turning it back on after disabeling

update-rc.d wdphotodbmergerd disable

update-rc.d wdmcserverd disable

Is the DNLA service necessary for accessing your photos through the web with an iPhone or iPad?

As a Newbie to the WD Community site I gave you kudos but would like to also indicate that your post solved my problem.  Is that function restricted to whoever posted the original question?

Thanks again for an excellent post. 

Ken VanBree


#79

DLNA is strictly a local LAN protocol and is never used for remote access

the 2 processes you listed are for thimbnail generation for the WD apps so if you use remote photos you want to enable them just change disable to enable, the # is not part of the command

then reboot or run the 2 lines below

/etc/init.d/wdmcserverd start
/etc/init.d/wdphotodbmergerd start


#80

I actually really like this device. It is currently configured at only 100MB LAN and wireless G, so it is pathetically slow (3Mbps).

I am pretty excited to see how it performs on my gigabit/wireless N.