Before you pack up your WD and return it, let's talk about Copying Speeds!


#41

before you pack up your WD and return it,…
it was so fuuny Topic for me!

how can you give your self permission to write this:
“” if you are having problems with copying files which seems to take forever… the problem is most likely “you” “”

I use 5Ghz N WiFi, my mycloud updated his self 1 month ago to fu…  4.00.00-607 version and it was SLOW until today I find a topic “Easy method to downgrade to previous version of the firmware”  
I downgraded my device to F/W v03.04.01-230. Now copying speed is like before fast as possible!

  • Why WD don’t want to accept that this version of F/W was a [Deleted - Trancer]?

  • Why you think we are the problem? Are we like a goat?


#42

PEYMAN wrote:

  • Why WD don’t want to accept that this version of F/W was a [Deleted - Trancer]?
  • Why you think we are the problem? Are we like a goat?

Lol.  Yes, it’s amazing isn’t it what consumers today are willing to accept and put up with?  I think many consumers are exactly that - goats or sheeple, take your pick!


#43

 I wrote to Ralphael

NOT TO YOU SIR!

Going via WIFI only
F/W 4.xxxxx  8.6MB/s
F/W 3.xxxxx 13.8MB/s

this is our problem!!

I don’t say anything about slow dashboard and other slow things in F/W 4.xxxx …


#44

PEYMAN wrote:

 I wrote to Ralphael

NOT TO YOU SIR!

Going via WIFI only
F/W 4.xxxxx  8.6MB/s
F/W 3.xxxxx 13.8MB/s

this is our problem!!

I don’t say anything about slow dashboard and other slow things in F/W 4.xxxx …

This is a public forum in a public thread in which I have previously participated.  Don’t get your panties in a wad - SIR!  If you prefer private communication use the messaging feature - SIR.


#45

Are you serious? we dont care why it’s slow.  That is your business , we just want it faster!!!  I take a nap in between any change I have to make to my panel.  :angry:


#46

I’m getting reasonable speeds because its sadtbehind a gigabit switch and my router and for large files i’m having to use a wired connection. Wifi copying speeds are ok nothing special. I can accept that. 

Things i dont get: 

  1. Randomly drops of network. Periods of 1-2 mins when copying large data files. (set to a static ip) 

  2. Stupid scanning program which runs and runs and runs then errors and  i have to reboot. If this happens cant acess drive via unc or explorer. 

  3. Maybe i’ve missed this but is there any way change frequency of this. I’m pretty sure this scanning thing messes up my nix boxes which are mounted with this nas. 

  4. The gui is slow.But again can work aroud that. 

I do understand the frustations though. I’ve had this 2tb My cloud for 1 day. And its stressing me out!  


#47

Well, I’m using it for more a few days and I have new thoughts about it.

1º I replaced all my network cables with CAT6 cables.

2º My modem have a gigabit switch.

3º My computers have gigabit ethernet cards.

So my network is gigabit capable!

After I replace my old cables I got a little boost on transfer speed!

Ok, that was my cables fault, but I never complained about transfer speed.

Before I got about 500~600Mbps, now I get about 800~900mbps in larger files.

I made a few tests on my network with iperf and my switch and cables handles properly 1 Gbps in dual mode (rx/tx same time).

Ok, so my network is not a issue anymore (never was, but ok).

Transfer larger files = GOOD, work as expected.

Transfer small files = ACCEPTABLE, probably protocol related.

When we transfer small files from Windows to Windows, the speed is a **bleep** too, but it’s still a little better than My Cloud.

Maybe this is a samba issue? version 4.0.0 RC5 (really?)

Sorry, but we are trusting ours files in a software in release candidate?

Ok, ok, probably it’s stable enough to work in production, but, call me cautious.

I can’t complain about the product itself, it works very well.

I think we have some problems with the SOFTWARE  only.

I’m having a good performance because EVERYTIME I restart my NAS unit, I stop the wdmcserverd.

Otherwise it consume all CPU time and the file transfer is a TOTAL **bleep**.

As I said earlier in my other post.
I’m not using any additional service (time machine, itunes, media sharing, etc.)

So why it’s still running and ruining everything!?

Now, my only complains can be resumed on:

  1. Samba using a release candidate version (probably more software are in the same situation)

2. wdmcserverd service eating all cpu resources, even when it probably should be disabled

  1. A power button! Why no one put a button on the case!? It supposed to work 24/7/365, but not for me

I know many factors can influence on the transfer speed, but I think the product it’s OK.

The problem is just the software, a few optimization can solve many issues.

It’s a product for home users, ok, but I think we should get some respect too.

If you do not want to waste time on it, release the software and let the community solve.

— Just to show that SPEED isn’t a issue here —

Moving from my PC (E: HDD) to NAS

moving from pc to mycloud.PNG

The blue circle represents the change from one file to another. (That’s ok)

The yellow bars I don’t have a clue, it’s the same file, maybe it’s related to HDD speed. (not really a issue)


Reading from NAS to my PC (C: SSD SATA2)

copying from mycloud to pc.PNG

Reading from NAS to my NOTEBOOK (C: SSD SATA3) (faster than my PC)

copying from mycloud to notebook.PNG

There are some drops on both, but they were very fast and didn’t impact too much on performance. (that’s ok too)

@Ralphael, a tip for you to put in your first post.

Check in the properties of the network adapter if there is no option related to energy savings

PS: Ignore my grammatical errors. English isn’t my native language.


#48

you can run the 2 commands below to avoud stopping it each time, just change disable to enable if you want to restore it

update-rc.d wdphotodbmergerd disable

update-rc.d wdmcserverd disable


#49

Ralphael, Hi I’m a little new to the cloud thing and a little late to the thread, but I have some questions that hopefully you or anyone can answer. And they are probably lame, newbie questions, so be prepared. I have read through this entire thread, so I tried to do my homework.

First question is in regards to the Belkin network adapter: I have discovered that my computer isn’t as cool as I thought. It apparently is using 100mbs(It’s a Macbook Pro Late 2011 - usb 2.0), and my router is a Verizon FIOS Actiontec MI424-WR. So if I purchase the adapter and plug it into my laptop’s usb, the ethernet cable now would move from the jack on the laptop, to the other end of the adapter, and then the other end stays plugged into the LAN slot on my router? Yes? And the second part is, would this even help if my router is only sending out 100? (At least I assume, that’s the number printed next to each of the LAN sockets with a flashing green light). Or do I need to get a stronger router?

My next question is: I bought the 4TB My Cloud NAS, and as far as performance, it’s doing pretty good. My internet speeds are 58 Mbps down/64 Mbps up, and the transferring of data,movies, etc. was pretty decent, no complaints. BUT. Now that I’ve got some stuff in there(almost 20% full) it seems to be slow if I try to open a movie file, sometimes timing out on the request. Also, I am having no luck with the website, wd2go.com. Every time I log in, and click on my device, the java warning comes up, and when I hit continue, the java symbol and loading wheel show up and freeze, rendering everything useless. I’ve been hearing of these java problems, but I’m clueless to the fix. Any?

And maybe this is also linked to java, but the dashboard app has been acting screwy too. Some fields that used to be accessable are now greyed out, and the ones that aren’t, if I try to make a change, the “updating” window pops up, and renders the page useless. No way to click on anything. Also, Info that used to be shown is missing as well, and it seems sluggish. Like some of the info boxes don’t have their info in them any longer i.e shares, content scan, users, cloud device, etc. Empty.

I know these are probably kindergarten questions, and maybe already solved somewhere else, but I’ve been pulling my hair out, pouring over google searches and forums for days(and I’ve only had the Cloud for less than a week!). I’d like to leave my computer desk eventually!!

As far as mobile access, that works just fine locally, so does the tv access, and a Roku in the garage. I even can access my device when I’m away from home, but it’s slower and not very consistent. Lots of buffering. But uploading remotely works like a charm.

Sorry for the long rant, but I need some help, and you guys seem pretty up on things here!

Thanks in advance!! 

Oh, and I’m updated with the latest firmware, so could that be hurting also? v04.00.00-607


#50

@Ralphael

Excellent post - really too bad it doesn’t come from the folks at WD (or better yet, that months later, a fix hasn’t been made). Not sure if you’re still crawling around the forums here, but I was hoping for insight on two items:

  1. As far as the services you’re disabling to make things work…what is being impacted in terms of functionality? Is the indexing only being performed for the media servers? Will I be sacrificing any other functions?

  2. I’m assuming this was all done with previous firmware (based on the vintage of the post). Have you used the most recent firmware release (4.00.00-607 as of 7/9/2014) - one would think the known issues would be corrected, but they have not. Recent firmware claims:

  • Resolved issue of device losing connection to the network.

  • Updated device read and write performance.

…though I’m calling complete “BS” on both, as I just bought a 3Tb drive and after a week of trials and tribulations, I still can’t get my data on. On the first drive (yes, there have been two - I returned the first one that bricked with a red light after a day), I managed to copy about half of my paltry 99GB of photos before the connection was lost, and the drive froze. On restart it went to white, then red light, and no reset would work

On the replacement drive, same issue (unbelievably!!), but the hard reset pulled it back from the red light abyss. After that, all the photos made it over (at about 3-4 MB/s), and I thought I was set, but now I can’t move movies, music, etc without it freezing up again and again (so I’m thinking of trying to stop those services you indicated).

As far as speed, my new PC and router will provide gigabit speeds (once I replace the household cat5 cable with cat5e), but regardless, the copying of data to the My Cloud device will have to suffer along at 100mb since my source machine is older. However, data is still only moving at 1-3 MB/s, which I deem to be unacceptable (99GB took 22 hours). My first move will be to try and roll back firmware, as from what I’ve read elsewhere, this more recent update has caused everyone’s speeds to suffer significantly and not increase!!!

Any insight (or advice from others)? I’ve wavering on SSHing in (if it might not work), because I don’t want to void anything - as of right now, this second one I have could still go back to the store if I decide to say “enough” with WD (which is REALLY too bad, because the supposed features and functionality are exactly what I’m after!) 


#51

Not positive the services you are asking about, I assume wdmcservd & wdphotodbmerged disabled with the steps below. as far as I can tell this is only for the WDphotos mobile app which seems flaky even with these running.

the stop lines just stop it for the current session, the disable prevents it from starting after a reboot. Changing stop to start & disable to enable restores it as is.

even though they say it may void the warrantee I doubt if they would try pushing it for a minor change like this.

/etc/init.d/wdmcserverd stop
/etc/init.d/wdphotodbmergerd stop

update-rc.d wdphotodbmergerd disable
update-rc.d wdmcserverd disable

On the firmware version my personal opinion dosn’t relly matter much unless you are loading other packages (much more likely to void the warrantee). I upgrade to V4 when I 1st got the mycloud, then downgraded to v3 due to performance issues which wern’t much better until disableing the services above. then I upgraded back to V4 and really have not noticed much of a difference as long as the services are disabled.

on a 100Mbps LAN 6-8MBps is about the max you would see, many small files are much worse.


#52

Thanks Larry, good to know yours still works fine - support is phoning me this evening, so I’ll repost if anything fruitful emerges.


#53

Bare with me, I’m pretty techy but NOT with networking.

I have a Macbook Pro running OS X Yosemite, an ArrisTM722G/CT modem from my cable company, a Netgear N300 Wirelss router (WNR2000v2) and a WD 1TB My Book Live.

The Ariis has ONE ethernet port which is connected to the Netgear wifi router.  The wifi router has One internet port (has the cable coming from the Arris plugged into it obviously) and 4 ethernet ports and one of those has the WD MBL plugged into it.

So WD MBL to Netgear to Arris.

The WD “Link” light is yellow in this setup and has been over 30 hours trying to do the inital backup of my Mac with Time Machine.  If I bypass the Netgear, I can get a green Link light on the WD but then I can’t connect my Mac.

I checked the speed as you directed in your post.  Connected to wifi I only get 100T.   If I directly connect to the Arris with an ethernet connecttion I get 1000T.

So here’s the dilemma: I only have ONE ethernet port coming from the cable modem.  I can connect the WD to it bypassing wifi but then have no way of talking to my Mac to back it up.  I’ve tried connecting the WD directly to my Mac but my Mac doesn’t recognize it.

How can I get this initial backup done?

How can I kepp wifi for all of the other needs in the house but bypass wifi for the WD?  Is there a way to have both the Netgear AND WD plugged into the Arris directly?


#54

the yellow indicates a 100Mbps connection and should never change over time, you need a new router to change this or an Gb ethernet switch

with a switch it would be arris - Netgear - switch to all other devices


#55

Hi Ralphael,

Great post and thank you!  When I figure out the Kudos I will send them along…

You mentioned that you planned on using you second device to automatically backup your first device.  I bought 2 4tb MyClouds with the same intentions but then found no good solutions.  Did you find a way to do this?  I’m on a Win+IOS enviroment, but I’m not against adding a Linux box if I need to (goodness knows I have WAY to many retired PCs sitting around my house lol)

Thanks!

Scott


#56

Hi Raphael,

Thank you very much for your great help.

I just have one problem for deleting .wdmc folders.

I followed successfuly :

/etc/init.d/wdmcserverd stop

/etc/init.d/wdphotodbmergerd stop

But, for the next commands :

update-rc.d wdphotodbmergerd disable

update-rc.d wdmcserverd disable

I get always the error message : -sh: update-rc.d: not found

Could you please help me ?

Thanks in advance.


#57

sounds like you path is not set correctly, at the Linux prompt enter echo $PATH and post the results

I forget where the command is but it is probablt /sbin or /usr/sbin so you could try the lines below

/sbin/update-rc.d wdphotodbmergerd disable
/sbin/update-rc.d wdmcserverd disable

Or

/usr/sbin/update-rc.d wdphotodbmergerd disable
/usr/sbin/update-rc.d wdmcserverd disable


#58

Hi larryg0

Thanks for your response.

The echo $PATH gives : 

/sbin:/usr/sbin:/bin:/usr/bin:/usr/local/sbin

I tried as you proposed :

/sbin/update-rc.d wdphotodbmergerd disable

/sbin/update-rc.d wdmcserverd disable

and 

/usr/sbin/update-rc.d wdphotodbmergerd disable
/usr/sbin/update-rc.d wdmcserverd disable

For all the same result,

-sh: /sbin/update-rc.d: not found

I really don’t know how to execute this update-rc.d commands…

Thanks again for your help.


#59

Hi ptiscarabee

I did the following and succeeded in stopping the services in question:

  • installed WinSCP from winscp.net on my computer

  • logged on using root / welc0me

  • checked where the update-rc.d file is; it sits in /usr/sbin

  • checked PATH; /usr/sbin is in PATH

  • executed to disable commands

maybe this helps?


#60

Hi Ivbaal,

Unfortunately, the update-rc.d file is not in usr/sbin, I had already checked. I don’t know where this file is located.

I made a “find . -name update-rc.d”, but no file has been found… I am not an expert, so maybe ther is another way to check where this file could be ?

By the way, I can’t log with root / welc0me, wrong password, maybe they have changed it, I bought the MyCloudEX2 for 2 days, it’s maybe knew.