Audio out of sync after switching audio track

When I switch the audio track the video gets into fast forward mode and the selected audio track plays normally. Does anyone else have this issue? I have this problem since i got my WD TV Live a your a go. None of the updates has fixed it so far. I’ve also tried a factory reset - no effect either.

Here the details of one of my movie files:

Format: H264, 1321.8kbps, 720×416, 25.0fps
MP4A, 159.9kbps, 48.0kHz, 2 channels

Demuxer: LAVF

Track Info: Video:1, Audio:2, Subtitle:1 tracks

Does anyone else have similar problems?

  • m

Just a simple question out of plain curiosity: Why on earth do you change the audio track during playback? o.o

The only option I’ve found to change the audio track is in the upper toolbar that appears during playback. There is no way to change it *before* playback. When I switch within the first 10 seconds of the movie I also have the same effect.

  • m

Does nobody else have this problem?

If changing audio tracks works for anyone please let me know.

Maby my box has a hardware defect.

  • m