Attach a supported WD drive

I get the message “Attach a supported WD drive” for both the WD Drive Utilities and WD Security apps.  Also, the WD Smartware app does not list the WD drive.  All apps have been updated to the latest version. 

I do see the drive and am able to write to it via Windows (7) File Explorer.

WD drive is connected via USB 3

The WD drive is a 1TB My Passport Ultra - P/N WDBZP0010BRD-05

S/N [Deleted]

Hello,

Try unisntalling and reinstalling the WD Drive Utilities, WD Security and WD Smartware. If the issue remains then i recommend you contact WD support directly.

Contact WD

I have same exact issues with my 2TB WD My Passport drive after upgrading all three apps to the latest version.   I am using Windows 7 (64-bit) and drive connected to one of the 4-port  of Anker USB 3.0 PCIe card. Both items purchased recently from Amazon.com  The drive works fine in Windows 7 OS file exploer.

Has anyone with similar issues got it resolved?  I am still waiting on for Technical support from WD on this. 

Thanks!

JS 

Hamlet, I was having the same issue.  I work on a Mac, though.  

I uninstalled the the WD Drive Utilities, WD Security and WD Smartware.  Unfortunately, it took me forever – well, an hour or so – to reinstall Smartware because WD’s website makes it do difficult to find anything.  

If anyone reading this thread has a similar issue and is looking for a link for the latest Smartware, here’s the link for Windows, and here’s the one for Mac.

After all that, I still can’t figure out how to attach a drive to WD Security or the WD Drive Utility.   This link provides directions for Windows but not for Mac.  I am now giving up.

 

 

Hey guys,

I have a WD My Passport Ultra 1 TB with the same issue.

Whenever WD Drive Utilities is started, it says “Attach a supported WD Drive”.

The WD drive is attached ofcourse, but still the same message. Any suggestions?

Kind regards,

Ivo

Hey guys,

It’s me again…
After a great struggle on different PCs and attempts to resolve the issue, I have tried one last step:
On the PC where I have originally had the WD Software installed, I have uninstalled everythin and installed it back again hoping this time it will work.

AND THIS TIME, everything worked as it is supposed to work!

P.s.
I have downloaded the WD SmartWare and WD Drive Utilities from this site and haven’t used the original CD that came with the device.

Hope you find this useful!

Have a nice day and good luck to all of you who have the same issue! :robottongue:

Hi Guys,

I get exactly the same problem but after uninstalling and reinstalling the latest versions of WD smartware, security and drive utilities on my windows 8.1 computer it repeats the same message. The drive (My Passport Ultra) has no problems in Windows 7 however!

Any suggestions ?

DON’T ANYONE GET FOOLED INTO UPDATING SOFTWARE!!! I cannot believe how many people have had this same problem and for how long this problem has been going on for, and still you have not figured out an acceptable solution.  I have wasted hours because your software said “you should upgrade, these are the updates… blah blah blah” so I did.  All I wanted to do was change my password and now I can’t do anything with the software.  I have uninstalled, reinstalled several times.  I thought you were a good company, but a good company would not put their customers through this.  When multiple people have the same exact problem YOU NEED TO FIX IT!!! Last time I purchase anything from you guys. Can’t spend anymore hours on this S***. Absolutely ridiculous.

In case anyone needs help with the message “Attach a supported WD drive” message in WD Security, I was able to resolve the error in my specific case by doing the following (I did it in Windows 7 but should work for XP and 8 if WD Security works on those OSs, must be done with administrative privileges):

  1. Close WD Security
  2. Navigate to the Control Panel, Administrative Tools, Services
  3. Look in the list for a service with the name “WD Drive Manager”, double click the service
  4. If the Startup type is set to Disabled (which in my case it was), change it to read Automatic then click Start, then Service status should read “Started”. Click OK
  5. Close the Services and Administrative Tools window, then open WD Security and the application should find the drive.

Good luck!

2 Likes

ab

This worked!! thank you so much

This was brilliant, thank you so much. I’m running Windows 10 and can confirm it works exactly as you said, with no problems, as of today.

The solution by Renzo_Rosales solved my problem of WD Drive Utilities version 1.3.2.2 failing under Windows 7 Pro with the message “Attach a supported WD drive.” My WD Drive is a My Book Duo, Product ID 0A10, purchased in 2017. In short, because the “WDDriveService” was not running, WD Drive Utilities could not locate the attached device.

hi, for the guys who are using Mac…need to do it thru the " Disk Utilities". select then the Drive then from the top click on Erase and then change the format from the pop up window to what match with your Macintosh …I have changed it to APFS (encrypted) and then click on Erase (make sure u copied all the documents you want on another volume before you erase the disk) automatically asked me for a password to create . and from Partition on the top, click on it and select the format.

make sure you copy all the documents before clicking on erase button.

I got this from the WD Support by Email:

The only Software compatible with your device is Data Lifeguard Diagnostics for Windows. It is why WD Security is not detecting your drive.
You would have to use a third party software to password-protect the drive

  1. If the disk contains any files you want to save, copy them to another disk or volume.
  2. In the Disk Utility app on your Mac, choose View > Show All Devices.
  3. In the sidebar, select the disk you want to encrypt.
  4. Click the Erase button in the toolbar.
  5. Enter a name for the volume.
  6. Click the Scheme pop-up menu, then choose GUID Partition Map.
  7. Click the Format pop-up menu, then choose an encrypted file system format.
  8. Enter and verify a password, then click Choose.
  9. (Optional) If available, click Security Options, use the slider to choose how many times to write over the erased data, then click OK.

I have this problem. I have tried a number of the solutions above in various permutations. Fortunately I have a solid state C drive so reboots are pretty quick because I’ve done a lot of them.

The WD Discovery program was reporting that it was out of date. The update mechanism withing the program doesn’t work but WD has an updated WD Discovery program that seems to work after it is installed.

But still no joy on getting WD Utilities to work

After I had a working copy of WD Discovery installed the options to update apps are displayed. It appears that no update for WD Backup is available, probably because it’s up to date. I clicked on the WD Drive Utilities update and that stalled about 75% of the way through. Then I clicked on the WD Secuirty update and that alos stalled about 75% of the way through.

The WD drive utilities still report " Attach a supported WD Drive" Maybe I need to uninstall the old WD Drive Utilities so the updated utilities can be installed?

So now I’m more than three hours in and still haven’t gotten WD Utilities to work.

OK, more than four hours in and I can run the WD Drive Utilities.

  1. Do not install anything that comes on the drive. :(:grinning: you probably wouldn’t be reading this if you knew not to do that)
  2. Assuming you foolishly installed the software that came on the drive, uninstall every thing that you can find of it with the uninstalll part of the control panel (Programs and Features)
  3. Download and install the version of WD Discovery from the WD website.
    https://support.wdc.com/downloads.aspx?lang=en
    “Install WD Discovery for Windows” is the option you want
  4. Run WD Discovery. You can install WD Backup, WD Drive Utilities and WD Security from there. According to the WD support guy, who was of little help with this problem, WD Security isn’t supported to work on the easystore drive I bought.

Another option, is to not install this software at all. WD Utilities seems to be something to monitor the functionality of the drive. Might be nice, but I’ve never had something like this before, and I don’t think my life as been worse because of it.

WD Backup seems to be a program principally aimed at backing up files to the WD cloud. Nice but if you’re already signed up for a different cloud server I don’t know that you will want this. I don’t know what WD Secruity does but I’ve decided to trust the WD guy and believe it doesn’t work with my drive.

ETA: I am sure that there are many other permutations of the above that might work . In five hours I certainly found a lot of permutations that didn’t work. It might be a good idea to just follow the above pretty closely unless you have a spare five hours you’d like to waste.

My Setup: Lenovo Desktop computer System Model 90ED000AUS with Windows 10
easystore 2TB USB 3.0 drive WDBKUZ0020BBK-WESN

I experienced the same thing with my windows laptop. I decided to uninstall the apps but I was not able to uninstall WD Drive Utilities because a message that a restart is required to uninstall it always appears and a restart did not uninstall it.

I am not sure what really happen but I force to uninstall the WD Drive Utilities using iobit uninstaller . The iobit uninstaller however did not uninstall the WD Drive Utilities but it deletes what it thought to be residual files which I believed it could be registry files.

Now the message “Attach a supported WD drive” does not show up anymore and I can use the app. I decided to install the other app which is the WD Security and it works fine. No more message "Attach a supported WD drive”. Not sure what happen but I hope someone can enlighten it.