Alternative Firmware (Debian Jessie, Synology DSM6)


#398

Yes, i still want to make a full-worked-firmware.


#399

Great - looking forward to it :smile:


#400

Is it possible to install Midnight Commander on MyCloud EX2 Ultra?


#401

Hello everybody :slight_smile:
I am new to this topic and tried to read more than 1300 comments so far …
I have a WD Mycloud Gen 1 and want to install DSM on it. In the past i experiment with Linux with my raspberry pi.
I tried to install DSM, but there is no how to guid or something like that. In the how to install stands i should look in the file > connect via telnet. But there is no such file?! Please help me. i just need a seamless installation guide.
Thank you all


#402

telnet is a tool that used to be present on all windows installations - that changed with 7 or 8, not sure.
You can either add it via add/remove programs| windows components or use an alternative tool like putty which also provides telnet functionality.
Then follow the steps in “Connect to WDMC via Telnet and run this commands:” …
Good luck::slight_smile:


#403

Use PuTTY instead. Its better.


#404

Hey Guys!

I was struggeling the last few day to get a clean Debian installation up and running on my WDMC EX2 Ultra 2 Bay NAS.

I tried to stick as close as possible to the information found here


The files I’ve used

  • uImage: WDMyCloud-Ex2-Ultra/Debian/uImage-4.8.6_ex2u.bin
  • Initrd: WDMyCloud-Mirror-Gen2/Debian/Dev/uRamdisk
  • root fs: WDMyCloud-Ex2-Ultra/Debian/MCMgen2-jessie-basic-armhf.tar.xz

What I’ve done so far

1. attached the hdd to my Linux machine and created the raid

parted --script /dev/sda "mklabel gpt \
mklabel gpt \
mkpart primary 0% 512MB \
mkpart primary 512MB 4096MB \
mkpart primary 4096MB 100% \
set 1 raid on \
set 2 raid on \
set 3 raid on"

mdadm --create /dev/md0 --level=1 --metadata=0.9 --raid-devices=2 /dev/sda1 missing
mdadm --create /dev/md1 --level=1 --metadata=0.9 --raid-devices=2 /dev/sda2 missing
mdadm --create /dev/md2 --level=1 --metadata=0.9 --raid-devices=2 /dev/sda3 missing

2. installed the rootfs

    mount /dev/md1 /mnt/root
    wget ...WDMyCloud-Ex2-Ultra/Debian/MCMgen2-jessie-basic-armhf.tar.xz -O - | tar xvJf -

3. connected via UART and booted from USB

usb reset; fatload usb 0:1 1200000 uImage-4.8.6_ex2u.bin; fatload usb 0:1 2000000 uRamdisk;
bootm 0x1200000 0x2000000

Result

the NAS stops booting with the message: # /dev/md1 not exist!

you can find my full bootlog here.


Has anyone successfully installed Debian on the WDMC EX2 Ultra yet?
Can you give ma a hint what i missed out or did wrong?

Thanks in advance
Marcel


#405

I think kernel dont have “md” module (Dont support software raid).
Try to use only one HDD w/o raid (/dev/sda[1,2,3])

Note: Ramdisk can boot to busybox with all needed for reformat (prepare) HDD (parted, mdadm, wget, etc…)


#406

Hello mr. Fox!

Thank you very much for the fast reply!

mdadm --create /dev/md0 --level=1 --metadata=0.9 --raid-devices=2 /dev/sda1 missing

works from busybox. so i thought the kernel supportts it? or dos booting from an array require additional kernel featuers?

i want set up a raid1 mirror.
Do i need to recompile my own kernel and recreate a ram disk?
Has someone done this previously?
Is it possible to install the os to the nand?

Thanks, thats how i do it now, didn’t realize it earlier…


update

found this guide here: https://themm.net/public/ex2u/start
going to try that tomorow…


#407

Yeah, sorry, my fault. Kernel is same, so md-module exist and work.
There another problem: Sometime (idk why) md0 transfer to md127 (md1 -> md126, md2 -> md125, etc…)
Reboot and check (mdadm -As && cat /proc/mdstat)


#408
/ # mdadm -As && cat /proc/mdstat
mdadm: No arrays found in config file

this method worked like a charm, install OMV faild due to systemd requirements…
later i tried to use docker with self compiled Kernel but it did not boot…


#409


Read “REQUIREMENTS” section. Need recompile kernel with these options for support Systemd.
Also you can build 3.10.70+ kernel from official Marvell GIT repository (Use Config and dts file from Mirror Gen2 + replace 0x2000000 (512MB) to 0x4000000 (1GB) in “Ram” section of dts)


#410

thanks for your help, but i wasted enough time on this ■■■■ now…giving it up now.
i am using a self build orangPi NAS (armbian) as private server, this is working perfectly stable for months with a total HW cost of around 30€ (wo. HDDs)!

i revert the original firmware and try to sell off this rubbish on ebay :smiley:


#411

Any word on if the DL2100 is supported ? @Fox_exe Thanks!


#412

There are some interesting repositories on github according DL2100 support:




#413

@Fox_exe

Still busy with work? Or any new release on the horizon?
Thx


#414

Sorry for the double post -
@Fox_exe
Was there any really stable release that would be ready for “productive” use or should I rather fall back to WD?
Need some kind of solution in place asap :confused:


#415

Hi !

Please can you explain clearly how to proced step by step.
I thing It will interrese a lot af beginner as me…
For exemple, you write : “Easy to install: Just upload my “special” firmware.”…Thank for that but where to find exactely your special firmware…?
Can you give the direct link…
The best : Write a tuto
Regards

Jean


#416

@Fox_exe Hi thank you for your great work. WDMC 2gen’s usb is still not working?


#417

Fixed. Download and unpack to /boot