Alternative Firmware (Debian Jessie, Synology DSM6)

@Fox_exe do you know any way to lower the CPU usage for smb file transfers in DSM6? Also noticing that I don’t believe all the memory is being used, very low memory usage compared to CPU.

I´m one more that will go for a UART boot thing to try to recover my drive. My unit keeps booting forever, with both blue drive LED lit and power blinking blue. Even if I remove both drives the LED keeps solid blue.

Do I still have a chance on reanimate my cloud mirror gen 2 or shoul I give up and buy a Synology 216j?:disappointed_relieved:

WDMC Mirror (Ex2 Ultra too) possible recovery only from UART.

From uboot env:

Its start to boot from internal flash. Usb/tftp/hdd complete ignored.
Yah, u-boot can boot from USB (Tested, worked. Support boot.scr). Possible to modify u-boot env (0x80000, mtd0).
So… Need backdoor if something happend - need modify u-boot boot scripts after buy this piece of s**t.
Or buy UART… “Thanks”, WD…

Yes, I also noticed that when I pluged the USB drive then apply the power, it would read the drive(the LED of USBDisk was blinking), but few seconds later ,the MCM2 sys LED blinked red. It read but wont start from that.

I have bought a UART adapter and its on the way. If it worded for me , I will write a guide for those who need!@Cricket-RJ

1 Like

Thx, mate.

A friend at work used to be an electronic technician, so he will look for a TTL to USB CP2102 at his stuff.

I had one arduino once for debrick an IP cam. I thought I would never use one again and thrown it away an year ago!

For those who needs a pic of PCB, these are My Cloud Mirror Gen2 board.

For those who are going to open it, beware of LED cable. If you don’t pay close attention you will break the weld and will lost LED function. It’s a thin 10 piece contact. Hope I can weld it back!

Where is the UART connection, by the way? Can someone point GND, TX and 3.3V on PICS 3 and 4?

@Fox_exe, feel free to upload this pics to your Google Drive since you have others PCB photos, but not these ones, I guess.

1 Like

On the second picture upper right:
O____O__O__|O|
RX GND VCC TX
But please check with a multimeter for GND could be switched with VCC.

1 Like

What I bought is one FT232RL UART adapter.

It’s said as the most compatible and stable module, more important, it supports Windows 10 which I am using.

1 Like

Not necessary to invent the wheel again and again and again…:
http://forum.doozan.com/read.php?2,28939,28939#msg-28939
(pictures at the end of the first post…)

A SATA-plug fits perfectly while it has the same 1mm pitch of the connector on the upper edge of the board, so it’s not necessary to disassemble the WDMCMG2, if your fingers aren’t too fat…

FTDI-UART-Interface work fine (even with Win10) and can be found for around 3 Euro in the bay.

1 Like

Do that means that I’ll still needs a UART, but don’t need to weld it? I can just use a SATA cable to connect to the UART?

Sorry about being so noob.:innocent:

If I understand correctly, yes it seems so.
O____O__O__|O|
RX VCC GND TX
The connections are routed to the notch, you can see these on the pictures. But you still need to solder such a cable and plug such a cable correctly in.

@JanN
Thanks for your post!

Yes, you can plug a SATA-cable on the boards edge and connect the other side with thin wires to the ftdi. I could make a picture if you think it would help you…

I’ve just bought 20 male to female jumpers, the FTDI and the soldering stuff. I guess I can simply use it as a bridge to the FTDI.

UART restore WDFirmware for My Cloud Mirror Gen2 guide updated(Will lost warranty! Use at your own risk) :

1.Pull out HDDs and manage to connect MCM2’s motherboard with UART moudle,and connect the UART to your PC , set like this [quote=“Fox_exe, post:63, topic:156551”]
Speed: 115200 bps
Data bits: 8
Stop bits: 1
Parity: 0
Flow control: off (xOn/xOff works too)
Codepage: UTF-8
[/quote]

2.Connet MCM2 with your computer directly using a ethernet cable, then set your computer IP as 192.168.8.1

3.Apply power for MCM2 and look putty for “Enable HD1” (sholuld be “Hit any key to stop autoboot” in fact, to void you miss that),when it come out, press [1] (or short circuit TX with RX) to stop start OS from NAND Flash, if it worked ok, you will see “Marvell>>”

4.Download two files from Fox here and set your PC as a TFTP server using “openTFTPserver”,put these two files in TFTP server folder. Then use putty to input these commands in this oder
set ipaddr 192.168.8.8; set serverip 192.168.8.1
tftp 0xa00000 uImage
tftp 0xf00000 uRamdisk
bootm 0xa00000 0xf00000

5.Wait a minute , then browse 192.168.8.8 and you will see the WD Recovery.

(I tried OK, not sure for others, or watch this to learn other skills here)

Update another usb boot attempt by @liuhangcheng

Say thanks to @Sellente, @JanN , @liuhangcheng and @Fox_exe , thank you! :relaxed:

4 Likes

Hello nice threads
I have a miror gen1 and I have seen on your GDrive an app Debian (WDMyCloudMirror_Debian_8.0-1.bin file).
What is it?
What is the use of it?
thanks

I would like also install DSM but I do not get so well the step to install (info.txt)

EN:

  1. Install wdfw-boot-to-dsm6-7321-test from WebGUI or Recovery.

  2. Wait ~5 min and connect to WDMC again (IP and MAC will changed!)

  3. Chose “Manual install”, use dsm6-7321-test.pat for installation (Not online method!!!)

  4. I guess it is wdfw-boot-to-dsm6-8xxx? How do you do it from WebGUI (it is the webconsole?)

  5. I guess it is now DSM-wdmc-mirror-8451.pat.

Old info. “Press [1] to stop autoboot” - correct.

Its chrooted debian jessie. Use it for install any software inside. (Note: our arch is “armhf”, not i686)
wdfw-boot-to-dsm6-8xxx - Its WD Firmware file. Use it in “Upgrade firmware” tab in WD web-gui.
After reboot you can see DSM installer (web interface). Follow instructions and install .pat.

updated the guide, thanks for reminding!:grin:

1 Like

Thanks
I will see it how this web interface by going to https://192/168…?

I should do this upgrade with my 2 discs in? or better to remove them?
If I remove them when I put them back they will be formated?

thanks for your help :slight_smile:

Thank you very much, such guides should be needed for every WD model and maybe Fox_exe could host it on his Gdrive?!

@KGreator
Is the exact ip 192.168.8.1 needed or could it be any ip?

@Fox_exe
Now I understand that “s**t” WD produced with WD Mirror Gen2. Can you modify the firmware/bootloader to change the bootorder?!